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Chapter 1: Welcome to HighDesign

▫ Introduction
▫ W h a t Yo u C a n D o W i t h H i g h D e s i g n
▫ Te c h S u p p o r t
▫ Installing HighDesign
▫ Standard and Professional Licenses
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Introduction
HighDesign is a 2D CAD (Computer Aided Design) application that lets you create projects,
technical drafts, and illustrations with powerful and intuitive drawing tools, an easy to use interface
and advanced project managing tools designed to increase your personal productivity.
Main features of HighDesign are:
• Powerful and intuitive drawing tools;
• Automatic snap to objects and grid;
• Simple and straightforward interface, designed to reduce to minimum the required space for tools
palettes and property bars;
• Compatibility with all other CAD programs via the most common file formats.
• Ability to freely modify your project via multiple Undos/Redos and advanced editing functions;
• Advanced commands to organize your project;
• A hierarchical structure of drawing items of types, groups, unlimited layers and unlimited sheets;
• Advanced search and precision selection functions;
• Customizable hatches and line types;
• Integrated help;
• Keyboard shortcuts and inline help to guide you through any operation;
• Automatic save and document backup;
• Unlimited project views;
• Image enhancement tools, like Mirror, Trim, Contrast and Brightness, Blur, Sharpen edges, etc.;
• High quality images output and real time antialiasing;
• Real time Zoom.

Furthermore, HighDesign Professional features an integrated scientific photogrammetry tool to
produce scaled elevations from virtually any kind of picture and knowing no more than two
dimensions: The whole setup process takes only 5 easy steps. With this tool, you can draw directly
over the original picture and get a correct and scaled drawing at the same time. No specific
knowledge is required.
Sharing your projects is easy with HighDesign: drawings can be exported into the most used vector
graphic file formats; printed at high quality onto any page layout; saved as high-quality images with
graphic eﬀects to present your projects.
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What You Can Do With HighDesign
HighDesign is a versatile application that can be used in many professional fields:
• Architecture, engineering and mechanical design;
• Photogrammetric survey such as:
‣ Planar facade survey, required in architectural restoration;
‣ Frescos, mosaic and wall paintings survey;
‣ Analysis of walls and flooring degrade;
‣ Vectorization of topographic and geographical maps.
• Architectural design with the aid of powerful tools like walls with automatic intersections, pillars
and columns, doors and windows, and customizable graphic symbols;
• Product design
• Home planning
• Interior design
• Illustration and page layout of drawings.

Tech support
Ilexsoft values quality support and is always available for your questions and comments. We
encourage you to use e-mail as the preferred medium to contact us, as it allows us to reply in the
shortest time.

How to contact us
E-mail:
• General Information: info@Ilexsoft.com
• HighDesign support: support@Ilexsoft.com
• Bugs, documentation issues and comments: feedback@Ilexsoft.com

Web:
• Home page: http://www.Ilexsoft.com
• Customer support page: http://www.Ilexsoft.com/support
Postal Address and Fax:
Ilexsoft SAS
Str. San Vetturino, 20/T
06126 Perugia, Italy
Tel: +39 075 38182
Fax: +39 075 3887729
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Installing HighDesign
The download version is a compressed Disk Image file (.dmg). Depending on your Internet
preferences, the file could have already been expanded after the download.
Once the file has been expanded, you should see on your Desktop (or your default download
location) the “HighDesign” dmg file. Double-click it to mount the drive.
To install HighDesign, drag the icon to a folder on your local or network disk. There is no required
location; however, if you have multiple users on your computer, put it in the main Applications folder
to make it accessible to all of them. Note that you will be required to log in as an administrator to
write to the Applications folder.

HighDesign Trial Version
When you download HighDesign from the Ilexsoft website, the software launches as a time-limited
trial version.
Limitations of the Trial version are:
• Operative for 30 days of use;
• Printed pages and exported images have a “HighDesign Trial” watermark;
HighDesign Trial lets you explore all the available features, including those of the Professional
version such as walls, sheets, views, photogrammetry, etc. At the end of the trial period, the
application will no longer launch.
For a detailed comparison between Standard and Professional licenses, see the next paragraph.
When you purchase a license, launch HighDesign and insert your Owner name and License Key into
the License dialog. There is no need to download a separate package.

Standard and Professional Licenses
HighDesign is available in two diﬀerent licenses to best suit your needs: a Standard and a
Professional version. Your serial number activates the matching license: there is no need to
download separate versions of HighDesign.
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HighDesign Standard is a CAD program designed to provide the user all the most used drawing and
editing tools. This version is intended for home and small oﬃce users who will benefit from its
powerful functions, ease of use and tight integration with the Mac OS.
HighDesign Professional includes all the features of the Standard version, plus many others
designed to increase personal productivity and satisfy the advanced needs of professional users
such as architects, engineers, designers.

HighDesign Professional features:
1. Sheets. Sheets help organizing a project by allowing multiple drawings with diﬀerent scales into
one document.
2. Project Views. Project views let you take snapshots of the current view of your project, including
position on screen, zoom factor, visible layers and sheets.
3. Tool Presets: save collections of settings of tools such as Texts, Dimensions, Hatches, Walls,
Columns, Windows.
4. Styles, to organize your project items and tools with predefined properties and behaviors.
5. Photogrammetry Tool. A scientific yet easy-to-use tool for surveying architectural façades and
planar surfaces from one image.
6. Render Tool. Creates high resolution pictures of the project with the ability to select tool options
and add filters.
7. Image Enhance Tool. An image editing program within HighDesign: flip, trim, grayscale, sharpen,
blur, invert, change brightness, contrast and saturation.
8. Import DXF/DWG blocks: Automatically convert any existing library of DWG/DXF symbols and
blocks to HighDesign-native symbols.
9. Parametric walls, pillars and columns with automatic intersections and customizable graphical
properties.
10. Convert To Wall tool.
11. Parametric Doors & Windows with scale-sensitive detailing.
12. Export to PDF tool: Create multipage, vector PDF documents with support for RGB and CMYK
color spaces, image compression and meta-data.
13. Customizable shortcuts: A Preferences Pane designed to assign key commands for shortcuts.
14. Delete Duplicates Command: A tool to easily remove all duplicate entities from an imported
drawing.
Professional only features described in this manual are marked with the badge PRO.
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2. Workspace

Chapter 2: Workspace

▫ We l c o m e w i n d o w
▫ Main window and toolbars
▫ Sidebar / Floating Panels
▫ Inspector window
▫ Radial menu
▫ Preferences
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Welcome Window
The Welcome Window opens by default
when you launch HighDesign and
presents the options to create or open a
project, open a recent document,
choose a template for a new project, or
open an example.
On the right side of the window you can
use the quick links to access the
D r a w i n g M a n a g e r w i n d o w, t h e
application Preferences window and the
Project Properties window. The “What’s
New” button opens the release notes
web page of the current version within
your default browser.
The “Guided Tour” button starts a short tutorial that describes and highlights the diﬀerent areas of
the main window: a popover window explains the corresponding functions of each area. Use the
“Next” and “Back” buttons of the popover window or the arrows of the keyboard to browse through
the diﬀerent elements of the main window.
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Main Window
Almost all of the main functions of HighDesign are visible and ready to use in the Main Window and
in the surrounding toolbars and Sidebar.

The main window in HighDesign Professional
On the upper edge (from top to bottom): Menu Bar; Edit and Transformation tools Bar; Methods
Bar (on the left) Properties bar. On the left side: Drawing Tools Bar. On the right side: Sidebar. On
the bottom: Input Bar. Surrounding the drawing area: Rulers (on the top and on the left); Scroll
Bars.
The toolbars provide essential functions, such as the drawing tools, the drawing methods, the input
fields and commands, the edit functions, and the properties controls. Through these commands,
arranged in logical areas, all the drawing functions are easily accessible.
The sidebar contains optional functions that are mainly used to keep the project well organized:
Sheets and Layers panes, Views and Overview panes, Object Info and Styles pane.
As any other Mac program, HighDesign has its Menu bar on the top of the window providing almost
all of the program features.
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Menu bar
As any other application, this is the horizontal bar placed on the top most edge of the visible screen
area and contains the following pull-down menus:
• HighDesign, the standard application menu. It contains the items “About HighDesign...”,
“Preferences”, and the standard application commands such as “Hide” and “Quit”.
• File, for file management (opening, saving, importing, exporting, merge and save special) and
printing.
• Edit, is commonly used for standard commands like undoing and redoing an operation; cut, copy,
paste and clear; selecting; searching function; arranging and aligning items.
• Drawing, is used to change the drawing scale and view, and to modify drawing items.
• Tools, contains more advanced functions such as “Photogrammetry”, “Render”, “Adjust Image”,
“Scale Drawing”, “Fillet”, “Chamfer”, etc..
• Organize, for project organization functions and tools.
• Window, is used to browse through the list of currently opened project windows.
• Help: access the Quick Reference, support links and repair the document.

Drawing Tools Bar
The drawing Tools bar is placed vertically on the left most edge of the main window. It contains
the buttons to activate all the drawing tools.
To activate a tool, click once on its icon. Some buttons show three dots in the bottom right
corner, meaning those tools have a specific tool options dialog as a pane of the tool Inspector
Window. To open the Inspector Window and change a tool settings, double-click on the icon.
Double-clicking the Panning tool (the open hand icon), activates the Fit To Screen command,
and the Zoom tool (the magnifier icon) resets the zoom of the current view to 100%.
Drawing tools can also be activated via keyboard shortcuts: each button has a corresponding
key on the keyboard. To see a tool shortcut, place the mouse cursor over the button and wait
1-2 seconds: a little window opens (called the Tool Tip) with the name of the tool and its
shortcut (e.g. “Arrow Tool (A)”).

When you select an object in the drawing, an orange frame on a tool icon shows the type of the
currently selected object.
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Methods Bar

The Methods Bar provides the drawing methods of the current tool, e.g. Line from one endpoint or
from its midpoint, or arc by center, by diameter, by three points, etc. This bar is contextual and
changes its contents according to the selected drawing tool and can include an additional input field
to quickly insert a parameter value.

Edit Bar
Placed on the top margin of the drawing area, the Edit bar lets you quickly access the main
functions used to edit the drawing with just one click on the icon. The buttons are contextually
enabled when the conditions for the use of the tool are met, like number and type of selected items.

Geometric Transformations

Object Editing

Composite Tools

Move

Find the intersections between Fillet two lines with an arc
two items

Duplicate

Intersect two lines

Chamfer two lines with a straight
segment

Multiply / Distribute items along a Extend one or more lines
line

Oﬀset, to create concentric
copies of the clicked objects at a
given distance

Multiply / Distribute items on a Split
circular arc

Extrude, to create a copy of the
selected objects with projection
lines

Rotate

Trim

Explode, to convert the selected
items into their base components

Angle of Rotation

Divide into parts

Convert to Polyline

Mirror

Break

Apply Hatch

Mirror & Duplicate

Calculate Area

Stretch

Find Center of Mass

Scale drawing

Fit Text box
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Properties Bar
The Properties bar is located at the top of the main window, just above the horizontal ruler and
below the Edit Bar. You can use it to quickly set the properties of the drawing items and change
those of the selected one.

From left to right:

•
•
•
•
•
•

Layer;
Pen color;
Fill color, gradient and transparency;
Line-type;
Start and end markers;
Pen weight;

Input Bar
Placed on the bottom of the drawing area the Input Bar provides all the controls to set the drawing
constraints and the geometric conditions.

From left to right:

•
•
•
•

the menu to activate the snap options;
the buttons to set the parallel, orthogonal and intersection constraints;
the menu to change the drawing units and the drawing scale of the current sheet.
Input fields: X, Y coordinates, length and angle. When drawing an item, the coordinates change
from absolute to relative coordinates dX and dY. You can switch between absolute and relative
coordinates by clicking the X and Y icons.

• The utility buttons and menus, to set the zoom level and the display mode of pen weights.
NOTE Depending on the available screen size, the appearance and contents of the Input bar
can change. At smaller resolutions, the Snaps menu includes the constraint functions, and the
zoom menu includes the Zoom to Fit, Zoom In, Zoom Out and Zoom Previous commands. The
input fields are always visible.
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Sidebar and Floating Panels
Important functions designed to help the user to organize the project easily
are displayed as panes on the Sidebar. If you select the “Floating Panels”
option on the Window menu, these panes will be displayed as three distinct
floating panels.
The Sheets pane

PRO

includes a list of all the sheets of the project and all

the commands to organize them.
The Layers pane shows the layers used in the project and provides the
functions to manage them.
The Overview utility pane displays a real-time 2x magnification of the
sector of the current pointer location on the drawing area; if the mouse
pointer enters the thumbnail, an overview of the entire drawing is displayed
and it is possible to centre the view of the project with a click.
The Views pane PRO shows a list of all the saved project views.
The Object Info pane allows to view and edit geometric information of the
selected objects.
Styles PRO is the pane used to create and manage Styles.

Inspector Window
Some drawing tools have more specific options and
properties that require an additional window for their
complete setup.
The Inspector window is a composite window made of
more panes; it provides all the controls to set the
graphic and analytical options of the current drawing
tool.
To open this window, double click on one of the
drawing tools that show the three dots near the tool
icon: the window will display the corresponding tool
pane.
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Radial Menu
The Radial Menu in HighDesign opens as a visual array of commands. These commands are
contextual, in that they are only active when appropriate for the current drawing and selection. The
icons are arranged in sections:
• “Organize” options;
• “Tools” commands;
• “Edit Lines” commands;
• “Drawing” commands;
• “View” options;
• “Edit” commands.

This menu does not provide additional commands: it is a
diﬀerent and more eﬀective way to provide the user with
all the most common editing, transformation and
organizing commands and options accessible in the
drawing area exactly where you do a click.
To activate the radial menu, right-click or Control+click on
the drawing area.

Rulers
Placed on the left and top of the main window, rulers help precisely draw and place objects in a
layout. Rulers show the current position of the pointer and the bounds of the selected objects and
are dynamically linked to the current measurement unit, drawing scale and zoom factor.
The button located on the top-right hand corner between the two rulers lets you place the new
origin: click it, move the orthogonal guides appearing on screen and click to set the new location.
On the right end of the top horizontal ruler, a button opens a pop-up menu which lets you select a
new measurement unit or open the “Units” pane of the Preferences window.
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Preferences
This dialog is used to set the application preferences to customize the work environment, interface
theme and usage options. In Mac OS X, you can open this dialog by choosing the “Preferences...”
item of the “HighDesign” menu. The Preferences window provides three panes: General,
Workspace, and Drawing. The Professional Edition adds two additional panes, Shortcuts for setting
and editing the keyboard shortcuts, and Templates to save and organize custom project templates.

General
This is the first pane you see when you open HighDesign Preferences. Through this pane you can:
• Choose the user’s language;
• Set the option to open the most recent document when the application starts up;
• Choose to check for new updates at application launch. Automatic checking only occurs at
application launch and no more than once in 12 hours. If there is no Internet connection available
or there are no new updates, the function is dismissed with no message.
• Set and adjust the automatic save options;
• Check the option to automatically save a backup copy of the current document;
• Change the maximum number of undoable actions, up to 300 actions;
• Activate the automatic undo reset with each save action (excluding the automatic save).
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Workspace
This pane lets you customize your HighDesign work environment. You can:
• Switch the interface theme between dark and light;
• Activate the full size crosshair cursor;
• Play sounds during drawing sessions;
• Choose not to display help messages;
• Use a classic contextual menu instead of the radial menu;
• Set the zoom speed when using the scroll wheel and invert the scroll wheel direction;
• Enable auto-scrolling on the main window. When this option is on, the drawing scrolls
automatically when, during a construction or editing operation, the cursor is inside the main
canvas near the margins of the main drawing area;
• Use the arrow keys to scroll the page and Shift-Arrow for nudging objects;
• Activate the long click to pan the drawing; to use the long click, press and hold the mouse or pad
button.
• Update default settings for a tool when editing a selected object. E.g. editing the text font of a
selected dimension will set the new font as default for all new dimensions.
• Set the default behavior of clicks with the Arrow tool. When this option is active, clicking an object
selects it and deselects any previously selected object; when inactive, clicking an object adds it
to the current selection.

Drawing
This pane lets you change the options for drawing and drawing tools:
• Drawing mode, which lets you set the way items are drawn on screen. “Click-Drag” is the classic
Macintosh method of click, hold and release; “Click-Click” is the standard CAD method of click,
release, move, click.
• Snap tolerance range, in pixels;
• Choose the pen weight display mode from “Hairline” (constant weight), “Bitmap Weight” and
“Print Weight”;
• End caps option, round or square;
• Freehand lines smoothing;
• Freehand lines tracing mode.

Shortcuts PRO
Use this pane to assign key commands and customize the shortcuts. It is possible to change
shortcuts for almost all commands of HighDesign menus:
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• File
• Edit
• Drawing
• Tools
• Organize
• Window
• Drawing Tools.
To change a shortcut, select one or more check-boxes corresponding to Shift, Option and Control
keys, double-click the field on the right and push the new key.

Templates PRO
The Templates pane of Preferences allows you to select a template from those already provided in
the HighDesign Library to be opened as default each time you launch HighDesign (architecture and
engineering templates according with the imperial and metric drawing standards, available in two
sheet sizes). You can also save the current drawing, including used layers, sheet size, units and
linetypes as a new personal template in the User Library.

Project Properties
In HighDesign the Project Properties window, available through the File menu and the Drawing
menu, includes the panes to set all the drawing options specific to the current project, like page
format and size, drawing units, grid, appearance and document info.
More detailed information about the use of these panes will be provided in chapter three.
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3. Basic Concepts

Chapter 3: Basic Concepts

▫ New Project and Project Properties
▫ Preparing a Project (Sheets, Layers, Styles)
▫ Groups and Symbols
▫ Managing documents (Save, Import, Export)
▫ Printing
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Create a New Project
When you launch HighDesign, the main window opens blank and ready to start a new project. The
default new document is generated with units and colors set according to the current preferences of
language and theme.
If you have closed all documents and want to make a new one, select File > New and a new window
will open.

Project Properties
Before starting a new project, it is useful to set up the main properties and drawing utilities
according to the drawing standard you wish to use in the current project, such as the page format
and size and the drawing units.
In HighDesign the Project Properties window, available through the File menu and through the
Drawing menu, includes the panes to set all the drawing options specific to the current project.

Sheet Format
The Sheet Format pane lets you select the current sheet size from a list of standard sizes (ISO,
ANSI/ASME and US ARCH) and activate the options for Page orientation and margins.
You can also open this dialog through the menu Drawing > Project Properties > Sheet Format or by
double-clicking on the “page” icon on the Sheets pane of the Sidebar.
Once you select the Standard, by clicking on the desired sheet size in the thumbnail, and you
choose the "Margins" option (Current Printer or Custom Margins), a visual aid will be displayed on
screen showing the page extents of the selected size and the corresponding print margins as a cyan
frame: you will use this aid to check if your drawing is entirely within the margins; that is, if you
chose the “ASME C” size, the frame would actually be 22x17 inches large. The available drawing
area does not change though.
This frame provides snapping to vertex on its four angles to help you with the set up of the layout.
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Sheet Units
Use this pane to set your preferences for linear and angular measurement units. Available options
are:
• Linear units, available as Millimeters, Centimeters, Meters, Decimal Inches, Feet and Decimal
Inches, Decimal Feet, Fractional Inches, Feet and Fractional Inches, Decimal Yards and Pixels;
• The number of decimal digits to be displayed;
• Angular units, selectable from Decimal Degrees, Degrees and Minutes, Degrees, Minutes and
Seconds;
• The number of decimal digits to be displayed when in decimal degrees;
• The option to use normal angles, bearings or azimuth;
• The direction of the North used by bearings and azimuth directions;
• Area units used to express area calculations and values;
• The decimal separator to use.

Grid
You can use this pane to customize the grid and set grid options:
• Horizontal and vertical size;
• Number of subdivisions;
• Grid color: automatic (changes with the current background color) or custom;
• Option to display the grid behind or in front of the drawing;
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• Option to print the grid;
• Option to set the snap to grid as exclusive;
• A button to show / hide the grid;

Appearance
This pane lets you customize your HighDesign
work environment. You can:
•Choose a background color;
•Select the color of selection handles;
•Choose to highlight selected objects;
•Choose the color of construction lines: by
object (through the Properties bar) or custom;
•Set the linetype of construction lines as
continuous or dashed.

Info
Use this pane to add information to a project, such as author name, copyright, description, status or
set a deadline of the project; Project Time shows you the time you have spent on the project.
If the project has a date due set, starting from fifteen days to the term HighDesign opens a pop-up
alert displaying the time left to the target date.
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Preparing a Project
As you work on a project, it is likely it grows in complexity as it comes closer to its final definition,
and includes several thousands objects that have to be organized in a clear structure.
HighDesign makes handling complex projects an easy process by providing powerful tools that help
you manage a project in a smooth and rational process.

Sheets PRO
As it is in manual drafting, a project is made of diﬀerent sheets, each with its own page size,
drawing scale and units, depending on the part of the project it represents. HighDesign provides an
intuitive way of handling projects by introducing the concept of “Sheets.”
A sheet in HighDesign has special attributes such as
visibility, write-protection, etc., that make it a
convenient way of organizing a project: you can, for
instance, put a diﬀerent drawing on each sheet or
use a sheet for the main drawing and draw details
on additional sheets.
This way a HighDesign project, be it of architecture,
engineering or illustration, is made up of several
drawings contained in a single document.
The ability to show or hide sheets, transparency and
write protection allows you to compose a complex
project in a single layout.
The following are some of the properties and of the advantages sheets provide:
• Independent drawing scale and size (ISO, ASME or custom sizes);
• Independent drawing units;
• Write protection and display mode (visible, hidden and dimmed);
• You can search and select items on a single sheet or on all sheets;
• Visible sheets can be merged into one;
• You can create and delete any number of sheets;
• The print functions only prints the visible sheets;
• A sheet can be saved as a new document;
• Sheets can be reordered and renamed; two or more sheets can share the same name;
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Sheets are managed through the Sheets Pane of the Sidebar and via the Organize menu, which
provide all the commands to create, rename, delete and reorder sheets, move and duplicate items
across sheets, show and hide, etc.

Layers
A layer is a concept used in CAD programs to conveniently group elements in a logical way. As its
name implies, this concept derives from the use of overlaid semitransparent papers in manual
drafting. As in manual drafting, layers are used in HighDesign to organize a complex drawing into
diﬀerent component parts, but, diﬀerently from real layers, each CAD layer has its own properties.
Decomposing a drawing into its components is one of the most important operations in computer
design. Any object, even the most complex, can only be analyzed by separating its elements in
logical groups, applying criteria that depend on the object nature and on the designer goal.
Any element of a drawing in HighDesign belongs to a layer: there is no restriction on what types of
objects you can assign to a layer. You are free to group diﬀerent elements together in the most
convenient way to you or according to the drawing standard you are following.
HighDesign layers have the following properties:
• Name: layers are identified by their name;
• Visibility: a layer can be visible or invisible. Items belonging to a visible layer are redrawn to
screen, are printable and selectable; invisible layers are not printed.
• Lock: layers can be locked to make their items not selectable.
• Color: layers can have a default 32 bit color. If the byLayer option is on (you can change it by
opening the “Colors” pop-up menu in the Properties bar and selecting “byLayer”), any new item
gets the color of its layer.
•Drawing tool binding: you can create a binding
between a drawing tool and a layer so that, every
time you activate that tool, the layer is set
automatically.
Layers are managed through the Layers pane of the
Drawing Manager window, available under the
Organize menu. More detailed information about the
use of the Drawing Manager window are provided in
chapter 7 “Organizing a Project”.
You can mask the layers of a project so that only
the current layer is visible and editable. Masking
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is a switch on/oﬀ command, and as long as the mask is active, changing the current layer will
automatically hide the other layers. Once masking is switched oﬀ, the other layers return to the
original visibility they had before the command.
Layers are document based and are only available to the project you created them for.
A. Current sheet B. Surfaces and externals
C. Walls, columns, doors and windows D.
Dimensions and text labels E. Symbols and
furniture

Styles PRO
In HighDesign Professional you can associate layers with graphic properties like colors, line-types
and pen-weights to create custom settings we call Styles. Therefore a style is a predefined set of
properties and behaviors that you can apply to graphic objects with a double-click: a style stores
the current settings of layer, pen and fill color, arrowheads, line type and pen weight, and can be
generic or tool-specific.
Generic styles can be applied to all kind of graphic objects. Properties that are not supported in one
type of object are ignored.
Tool-specific styles apply only to the tool they were created for. When you click a tool-specific style,
the corresponding tool and method activate. This type of styles also include all the properties
specific to their tool. For example, if you create a Text style, it stores the current settings of the Text
tool, such as font, size, alignment, etc.
By default, a style exists only inside the document it was created in. However, you can save a style
on disk and load it in any other document.
Styles can be created and managed through the Styles pane of the Sidebar. You can open a dropdown menu by clicking the triangle to the right of the name of a style on the Styles window.
To learn more about creating, selecting and managing Styles, see the Styles pane paragraph in
chapter 8 “Sidebar and Panes”.

Groups
In addition to sheets and layers, HighDesign provides the ability of grouping diﬀerent objects
together as a single item. Most editing operations and transformations can only be applied to
selected items, either to individual objects or to a group of objects at once.
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Groups are a convenient way of joining objects that must behave as a single item. When you select
an item that belongs to a group, all group members are selected as well.
A group is an object like the others, and as such it can be transformed and edited with the
commands of the Edit bar. Rotation commands are applied to the group members, but the bounding
box is always aligned to the cartesian axes.
A group can be resized and moved with the Arrow tool. Properties applied to a group are applied to
all the group members. Groups are managed by the corresponding items of the Organize menu.

Symbol Libraries
One of the most time-consuming operations in a CAD project is duplicating the same group of items
(for instance, a window on one elevation) several times and in diﬀerent locations. Making tens and
hundreds of copies of the same items can also significantly slow down the redraw routine and
overload the document.
Symbols are an easy way to solve this problem, since Symbols are actually entire drawings or
portions of drawings already created and stored in a library that you can put in your project with just
one click. Instead of making copies of a group of items, a symbol lets you display instances of one
drawing in diﬀerent locations and with independent sizes, rotation angle and properties.
HighDesign symbols also provide an essential feature: multiple views of the same symbol. Each
symbol can have diﬀerent views (e.g. “Plan”, “North Elevation”, “West Elevation”, etc.), but you can
also use views to make symbol families, like “Bolts”, “Steel shapes”, etc.
Symbols, ordered in the default HighDesign Library or in the User Library, are available through the
Symbols tool of the Drawing Tools Bar. It is possible to extend the Symbol Library by creating
custom symbols and by adding external libraries of symbols.

Drawing
To start drawing with HighDesign you select the drawing tool you wish to use and set its properties
if needed.
In addition to the mouse, HighDesign supports trackpads and pen tablets, specially useful when
tracing a drawing over an image.
The drawing procedure adopted in HighDesign is “Click-Move-Click,” i.e. to draw a line you click to
set the start point, move the pointer to the desired location and click again to set its end point.
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Some tools, like the Polygon tool, need a double-click to set the end-point.
To cancel an operation you can hit the “Esc” button on the keyboard, or press the right button of the
mouse.

Managing Documents
All the functions needed to correctly manage your documents are available in the “File” menu, and
many of them are easy to understand as they are standard commands in all applications.

New Document From Template PRO
Through this function you can use an existing template for the new project: this preset includes
properties like units, sheet size, layers, linetypes, hatches, title blocks and graphic objects. Default
templates are available with the imperial and metric drawing standards of architecture and
engineering.

Open a Document
To open a HighDesign project stored in a known location, select File > Open...; if you want to quickly
open a recently modified document, choose File > Open Recent > “project-name”
The “Open...” command also lets you convert and open “.dsn” files from previous versions of
HighDesign.

Merge Two Projects
Select File > Merge... to open a project inside the current one: the merged project will contain layers,
sheets and symbols from both source projects.

Save a Project
The “File” menu includes all the basic functions to save the current document to the desired storage
location:
• “Save” lets you save on disk the current project; if the project does not have a name, a standard
save dialog is shown on the screen.
• “Save As...” saves a copy of the current document with a new name;
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• “Save Special” has a sub-menu:
‣ “Selection As New Document” saves the currently selected items into a new file;
‣ “Sheet As New Document” (Pro version only), saves a copy of the current sheet into a new
file;
‣ “New Symbol” lets you save the currently selected items as a new library symbol;
‣ “Symbol View” lets you save the selected items as a new view of an existing symbol;
‣ “Template” (Pro version only) stores the current properties and graphic objects as a
reusable template.
HighDesign Projects have the “.dsn” file name extension.

Inserting an Image
HighDesign lets you easily add pictures to your project from several graphic formats (TIFF, JPEG,
PNG.). Images inserted into the project keep their resolution and are displayed at the real print size:
it is also possible to handle them as any other vector entity. PNG and TIFF images are imported with
their alpha channel if present.
To insert a picture in your project, select File > Insert Image..., choose the image and place it at the
desired position with a click.
If you use the Pro version of HighDesign, you can also enhance the image by adjusting brightness,
contrast, saturation, size, sharpness, smoothing factor, etc. To set size on screen, print size,
resolution and transparency of images, use the Image Inspector on the Edit menu.

Importing Drawings from Other Programs
It is possible to import projects saved by other CAD programs by using the DWG/DXF file format,
which HighDesign supports from version R9 to 2015.
Select File menu > Import > Single DXF/DWG file. Before opening a DXF/DWG file a dialog lets you
set the basic import settings.
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DXF/DWG import dialog.

•

Drawing units to be used to convert DXF/DWG elements; most DXF/DWG versions do not
include a measurement unit.

•

Destination scale of the drawing.

•

When the “Use file drawings units” option is active, HighDesign tries to set the drawing units as
found in the file. If no drawing unit is found this option has no eﬀect.

•

Options to set the background color to black or to add a prefix to layers.

HighDesign imports DWG/DXF documents with both Layouts and Model data: when opening the
document, the drawing, or Model, is located on the sheet named “Model” and the Layout objects
are located on a sheet named “Sheet 1”.
Viewports are translated as Print Areas, with the label showing the viewport index and its zoom
factor, e.g. "VIEWPORT 2 - 1:1.27". Since in HighDesign there is no viewport implementation, paper
space viewports are imported with a duplicate on the model space sheet, which is usually named
"Sheet 0". This duplicate print area has the same name as its original on Paper space, but a
diﬀerent zoom factor. To match the items on paper space, like labels and leaders, to the drawing on
Sheet 0, you need to:
• Resize the paper space objects by the factor showed on the label of the print area, if other than
1:1. For instance, a print area with a zoom factor of 1:1.27 would be resized by a factor of 0.787
(1/1.27=0.787), that is, 78.7% in the Scale/Resize drawing dialog.
• Move the resized objects by picking the top left corner of the paper space print area and match
the top left corner of the corresponding print area on Sheet 0.

Importing DWG/DXF blocks PRO
Use the “Import DWG/DXF Blocks” tool to convert a folder of DXF/DWG blocks or drawings to
HighDesign-native symbols. Converting a symbol library is a two-step process, all performed in a
single window.
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In the File menu, choose “Import > Import DWG/DXF Blocks...”; the following window opens:

A. Conversion options: convert blocks/drawings within one folder or blocks within one DWG/DXF
file. Push the Choose button B. When the import process is complete, you can use the table to
review and edit the imported symbols. C. Preview of the symbol. D. Click the Convert button to save
the HighDesign symbols into your current Library folder.
The list of symbols can be reordered by dragging the rows.
The first step consists of selecting the folder on your disk and importing all the readable drawings
contained in it. Supported formats are all DXF versions from R10 to 2013 and all DWG versions from
R9 to 2015.
Push the Import button to choose the folder. If the selected folder contains readable files, the
standard DXF/DWG Import dialog opens allowing you to set the scale and drawing unit options.
With the second step you can set the options and complete the conversion to HighDesign symbols.
The table displays name, scale, width, height and the preview of each symbol, letting you modify the
attributes of the symbol before it is saved.

Exporting Your Project
Your project can be exported to many graphic formats. Select File > Export As and choose the
destination file format:
• DWG™ file format from version R12 to 2015 (.dwg);
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• DXF file format from version R12 to 2015 (.dxf);
• DXB (.dxb) versions R12-2015;
• Vector PDF (.pdf) - (Pro);
• TIFF (.tif);
• JPEG (.jpg);
• PNG (.png);.
The Export as DWG/DXF dialog shows some options:
• Format version via a pop-up menu. Also available in HighDesign Standard;
• List of sheets of the HighDesign project and ability to select sheets to export;
• Option to export all selected sheets as a single DWG/DXF document;
• Option to export each selected sheet as a separate document (all documents are collected in one
folder).
When you export a drawing to JPEG, a dialog lets you set the compression quality and JPEG
specific attributes.
On the right half of this dialog, a preview shows the new file and the original image.

Export to PDF PRO
With this function it is possible to create single
page or multiple pages vector PDF documents
which can be edited with other applications
and printed with large format printers and
plotters.
A. Document pages: “Single Page” creates a
one-page PDF document; “Multiple Pages”
creates as many pages as the visible sheets.
B. Include copyright info: this option adds
information about the project from the Info
pane of the Project Properties window.
C. List of the sheets of the current project:
select the sheets to include in the PDF
document.
D. Page Size menu. Available options are:
•

Fit Drawing Extents: page sizes are calculated on the extents of the drawings.
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•

Available Sheet Size: this sub-menu lists the sheet sizes of project if already set; all sheets get the size from the
selected one.

•

ISO, ANSI, US ARCH standard sizes sub-menu.

E. Orientation of the selected page.
F. Option to apply the Quartz filters to the PDF document by choosing from the menu.

Extending the default Symbol Library
Even though HighDesign comes with a default collection of symbols, it is possible to extend it by
creating new custom symbols or by adding external libraries: the “Add Symbol Library” command
lets you select a folder of HighDesign symbols to be stored in the desired location within the
Custom Library folder.

Printing
The print function produces high quality prints on any page format supported by your printer.
The basic concept behind printing in HighDesign is “what you see is what you get”, meaning that
not only the printed page will look as much as possible as the drawing on screen, but also that no
scaling, hiding or other operations are required in order to print the drawing. If the project includes
sheets at diﬀerent scales, they will be printed with the same relative proportions.
All print operations are performed by selecting one of the print items in the “File” menu.
• Page Setup: opens the standard page setup dialog of your Operating System. Use this dialog to
select the printer and set page size and orientation.
• Print: opens a dialog to set HighDesign specific print settings and get information about actual
drawing extents and number of pages that will be printed.
Some items of the project are not printable: Print area frames and Selection handles.
Construction objects such as datum points, grid, and construction lines can be printed if the “Print
Construction Objects” checkbox in the Print dialog is active.
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Print Areas and Project Views
HighDesign provides the Print Area tool, a special tool designed to create rectangular areas of the
drawing to be printed as details of a larger project. The “Printable Area” pop-up menu in the Print
window allows you to select a print area from those available. For a detailed description of the Print
Area tool, see chapter 4 Drawing with HighDesign.
In HighDesign Professional The Project Views pane of the Sidebar allows you to create new views of
your project and browse through existing views.
A project view stores the visibility status of current sheets and layers and though this function, for
instance, you can create a "layout" of a plan with dimensions and surfaces and another "layout" of
the same plan (sheet) with services only, just turning on/oﬀ layers accordingly.
By combining visible sheets and layers you can create complex project views for your printouts: in
the Print window you can select the Project View you wish to print through the Views menu.

Print
This window contains the Project View pop-up menu, to choose the view you want to be printed
with its corresponding set of visible sheets and layers (Pro-only feature), the Layout pop-up menu,
used to set the position of the printed drawing relative to the pages, and the Printable Area pop-up
menu, providing a list of possible print options. Available options are:
• Whole drawing: prints all items on visible sheets and layers;
• Selected items: only prints currently selected items;
• Print Areas: from a list of available Print Areas, this options only prints the region of drawing
included within the print area bounds.
The Print button opens your printer’s Print Settings dialog. This dialog may include diﬀerent panes
for each printer manufacturer.
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A. Views. PRO Use this menu to select a project view to automatically show and hide sheets and
layers accordingly.
B. Preview.
C. Actual extents of the drawing being printed.
D. Print Resolution menu. Set resolution from 180 to 1200 dpi (600 dpi is the default).
E. Position of the drawing within the page.
F. election of the printable areas. Options are: Whole Drawing, to print all the visible objects in the
drawing; Selected Items, to print only the objects currently selected; any available print areas
created with the Print Area tool.
G. Print options:
• Option to scale the printed drawing to fit the current page.
• Print pen-weights option: uncheck to print everything as thin lines.
• When “Fit to one page” is set, the Scale pen weights option allows you to choose whether the
pen weights should be scaled to match the new zoom factor of the printout.
• Print margins option: if checked, small angles are printed at the corners of the available
printable area on each page.
• The “Print construction objects” option prints objects like points and construction lines.
• Option to print all colors as monochromatic and colors menu. Filled objects keep their fill color.
H. Number of pages required to print the drawing (rows x columns).
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4. Drawing with HighDesign

Chapter 4: Drawing with HighDesign

▫ D r a w i n g To o l s
▫ V i e w i n g To o l s
▫ Snap
▫ Drawing Constraints and Input Bar
▫ Properties
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Drawing Tools
Arrow and Selection
The Arrow tool lets you select drawing objects by clicking directly on them or by dragging a
selection rectangle. To select an object, click on it with the arrow tool. Snap to Objects must be
active so that the arrow tool can “see” the object you are clicking.
Press Shift while clicking to add items to the selection or remove already selected items. Click on a
blank part of the screen to deselect all.

METHODS:
Rectangular selection: click on a blank part of the screen and drag the pointer
to draw a rectangle: objects with control points within the rectangle will be selected.
Polygonal selection: this function allows the user to select objects with the
control points within the polygon drawn by clicking on its vertices.

Both Rectangular and Polygonal selection can
be used in two ways: “Inclusive”, which is the
normal way and selects all the items that have
at least one control point within the selection
area; “Exclusive”, which can be activated by
pressing the “Option” key, has a dashed
outline and selects only the items that have all
control points within the selection area.

Holding down the Shift key while using the selection rectangle adds objects to the selection.
Selecting overlapping objects. When two or more items
overlap it can be diﬃcult to select the right object. To get
a smart selection, activate the Arrow tool, hold the Control
key and click on the intersection to open a contextual
menu listing all the objects top to bottom.
The Arrow tool can also be used as an all-purpose editing tool: most of the tool-specific editing
actions, such as resizing a line or editing a text, can be performed with the Arrow tool. Clicking a
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selected object on its outline, but not on a vertex, will activate the Move function. Hold down the
Command key to move any object, selected or unselected, by any of its vertices or by its outline.

Object Type

Editing Action

Line

Resizing; moving by center: click the midpoint of
the selected object to move it. Hold down the
Alt key to duplicate the object while moving it.

Construction line

Moving.

Rectangle

Editing vertices; stretching by midpoints of
sides; moving by sides and center.

Polygon

Editing vertices; moving by center.

Freehand line

Editing control points.

Bézier curve

Editing control points.

Arcs

Editing angles; resizing; moving by center.

Circle / Ellipse

Editing angles; resizing; moving by center.

Text

Resizing; editing text content; moving by center.

Linear / Angular Dimension

Resizing, moving the label by center.

Wall

Resizing; moving by center.

Fill / Hatch

Editing vertices.

Construction Objects
This tool can be used to mark reference elements in the drawing.

METHODS:
Datum Point: click on the desired location to insert a point or press the X and
Y keys on the keyboard to enter its coordinates. In the Print window you can
choose to print datum points and construction lines.
Construction Line: allows you to create infinite lines: click to set the center
and direction or enter the angle by pressing the A key on the keyboard or click
an existing linear object to draw a parallel construction line. To set the distance of the
construction line from the reference linear object, press the L key on the keyboard, enter the
value and click on the desired location. Construction lines can also be drawn as horizontal
and vertical guides: drag them from the rulers to the desired location. Construction lines can
be moved with the Arrow tool.
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Absolute Origin: click to change the origin of cartesian axes and rulers. The
coordinates of the drawing and dimensions are updated automatically. You
can also change the Origin by using the button on the intersection of the rulers. In HighDesign
Professional each sheet has its own Origin.

Lines
Probably the most used tool, the Line Tool allows you to trace straight lines of any length and angle
from a start point to an end point.

METHODS:
• Single Line: Draws the line from one endpoint to the other.
• The Line by Center method creates lines by midpoint and
half-line.
• To draw a Segmented Line, click to set the first vertex, then
click to set the next vertex. To end the path, double-click on
the last vertex. Each segment is a separate line.
• Double Line method creates two segments of the same
length and angle with an oﬀset you set by entering the value
on the “Oﬀset” field next to the methods icons. Double lines
can be traced from the axis or from one side.

The standard procedure to draw a line of a given length is to set the first point, push the “L” key (or
the corresponding shortcut), enter the value and push the Return key. The same procedure applies
to Angle (A), X, Y.
For more detailed information on drawing constraints, see the Drawing Constraints and Input Bar in
this chapter.
To resize a line, select it and with the Line tool active click one endpoint. Click its midpoint to move.

Polyline
The Polyline tool is used to create a polygonal shape made of a connected series of straight and
curved segments. Curved segments are arcs drawn by center or by tangent.
To draw a polyline, click to set the first vertex, then click to set the next vertex. To end the chain,
double-click on the last vertex.
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While creating a polyline, an action icon follows the start point of
each segment. Click it or hover on it to open the options menu and
choose the type of the next segment, delete the last segment or
end the shape. To close the polyline, select the corresponding
option or place the last vertex on the first one.
A polyline can be edited in many ways: activate the Polyline tool
and select the object (if it’s not already selected); then you can
click on a side to add a vertex, drag one vertex to change its
position or place it over another vertex to delete a side. You can
also hover the cursor on a vertex to open the edit menu with the options to delete the vertex or add
another one at the midpoint of the previous segment.

Polygons
Use this tool to draw rectangles, squares and regular polygons of any number of sides. Polygons
have a fill property with color and transparency: choose edge and fill color on the Properties Bar.

METHODS:
Rectangle: to draw a rectangle, click to set the first vertex, move the
pointer and click again to set opposite vertex. You can add diagonals
to a rectangle by pressing the Option key on the second click. To draw a square, use the
rectangle tool and hold the Shift key to constrain the diagonal direction.
To set the size of the rectangle, click to set the starting vertex, then push the “W” key to set
the width and “H” to set the height. Positive values go rightwards and upwards. To edit the
rectangle with either the Arrow tool or the Drawing tool active, click on vertices to resize, on
midpoints of sides to stretch, and click on sides or center point to move.
Rotated Rectangle: click to place the first vertex, move the pointer
and click again to set the base angle; then move the pointer and click
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a third time to set the height of the shape.
To set the dimensions, click the first vertex, push the “A” key to set the angle, the “W” key for
the width and the “H” key for the height.
Regular Polygon by External Radius: this method
allows you to draw regular polygons with any number
of sides starting from three. To set the desired number of sides, use the oﬀset field in the
Methods bar next to the tool methods and insert the value.
To draw a Regular Polygon by the external radius, click to set the center of the shape (all
these regular polygons are inscribed in a circle), move the pointer and click again to set the
radius of the circle circumscribed and the vertex of the polygon.
Regular Polygon by Internal Radius: this method
lets you draw the polygon by setting the center and
the radius of the circle inscribed in the polygon.
Regular Polygon by side: to create the polygon,
draw the first side, exactly like a line of the desired
length and angle, and click again to place the shape at the desired location.

Hatches and Fills
Use the Hatch tool to fill polygonal regions with a color or with a vector hatch. Hatches can be
chosen from a list of types: HighDesign comes with a wide range of built-in hatch-types that can be
easily extended with your own types. You may also merge fills and hatches.
To set or edit hatch attributes, select Edit > Properties > Hatches or double-click the corresponding
icon in the Tools bar to open the Hatch & Fill properties dialog.

PRO

In HighDesign Professional, values and current graphic settings can be saved as presets

via the Preset pop-up menu: use this menu to display and select saved presets.
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Hatch and Fill Properties
A. Preset menu.
B. Border: select to display the bounds of the hatched
region.
C. The Hatch checkbox enables the vector hatching of the
region; the color of the hatch can be selected via the Pen
Color menu on the Properties bar. To display the fill, use
the Fill Color menu on the Properties bar which also
provides the slider to control the opacity of the fill.
D. Scale Factor: use this slider to scale the hatch
spacings and oﬀset.
E. Rotation: controls the rotation angle of all the patterns
of the hatch.
F. Draw at scale: when this option is selected, the hatch
spacings and oﬀset are scaled to match the current
drawing scale.
G. Hatches table: lists all installed hatch types, including
any custom types.
H. Button to add hatch types to the current project: this
option opens the “Hatch patterns” pane of the Drawing
Manager window.

To draw a fill region, use this tool in the same manner as the Polyline tool or select an existing
polygon and choose Tools > Apply Hatch. While drawing a Hatch / Fill region, it is possible to delete
the last vertex with a click on the X icon close to it.
To edit a vertex of a hatch region, select the object and, with the Hatch tool active, move the pointer
over the vertex till the tool menu shows up with the edit options.
To add a vertex, click on one side or click on the “Add Vertex” option of the menu; to erase a vertex,
move the pointer over that vertex and click on the corresponding option of the tool menu.

Create openings in existing hatches
You can create polygonal openings in existing hatches by
drawing the shapes of the islands within the selection. To
do this, just activate the Hatches & Fills tool, select the
hatch and click on the vertices of the polygonal opening
you wish to create within the selection.
To edit the island, select the hatch and locate the pointer
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over one vertex of the opening till the tool menu shows up giving you the options to remove the
island, to delete one vertex or to add another one.

Circles, Arcs and Ellipses
Use this tool to draw circles, arcs, ellipses and arcs of ellipse.

METHODS:
• ARC / CIRCLE defined by center and radius: to draw an
arc click to set the center (or set it with the coordinates),
then move the pointer and click again to set radius and
start angle; with the next click you define the end angle
of the arc. To draw a full circle, double-click on the first
vertex of the arc. It is possible to set the length of the
radius by pressing the “L” key on the keyboard and the
start angle / end angle by pressing the “A” key.
• ARC by its diameter: click to set the first vertex of the
diameter, move the pointer and click again to set the
second vertex.
• ARC defined by three points: click to set the points that
define the arc.
• ARC by tangent: click on the endpoint of a line or on the
endpoint of an arc to set the first point of the arc drawn
by the tangent to that object at that datum endpoint.
• OVAL defined by its bounding box: draw it as it was a
rectangle.
• ELLIPSE by radii: click to set the center of the ellipse,
then move and click to define its first radius; move again
and click to set its second radius.
• QUARTER OF ELLIPSE: this method allows you to draw
quarters of ellipse by clicking on its two vertices.
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Curves
The Curves tool allows you to draw freehand lines, single and multiple Bézier curves, Spline curves
and clouds.

METHODS:
FREEHAND LINE: use this method to trace non-regular curved lines: they
are specially useful to add your personal touch to a drawing, trace over
images and everything else you would do “by hand” such as terrain levels and archaeology
surveys.
Freehand lines are smoothed, that is over-defined segments will be simplified once the line is
drawn, thus reducing its complexity and making it quicker to be redrawn on screen. You can
adjust the smoothing factor of freehand lines in the Preferences dialog > Drawing pane: 0
means that the line will preserve its original shape, but might contain many vertices; 5 is the
maximum smoothing and the line will change slightly its shape, but will be a lot faster to
redraw and have a more regular appearance.
In the same pane, you can also choose to draw freehand lines with a click-drag method
instead of the standard click-click: this option is specially useful when used with a pen tablet,
because it allows a more natural way of drawing with a pen.
Bézier Curves can be used to draw parametric curves defined by two
vertices and two tangent lines.
To draw a Bézier curve, click to set the first vertex, move the pointer and click to set the next
vertex; this method allows you to draw multiple, connected Bézier curves: this way the first
tangent of the next curve is always defined by the previous one. Double click to end the chain
of Bezier curves. Bézier curves with only two vertices looks like a straight segment: edit the
tangents to adjust its shape.
Bézier curves have the Fill property:
select the desired color on the “Fill
color” menu of the Properties bar.
Editing a Bézier curve.
By clicking on one of the four control
points of a selected curve, you can
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change its position and visually adjust the profile. With multiple Bézier curves, by editing a definition
point the connected tangents are constrained to keep the same angle: move the control points of
the tangents to change the angle and adjust the shape of the curve.
Hold down the Alt key while moving the control points of the tangents to edit asymmetrically; Alt key
+ Command key to disconnect the tangents.
Spline curves in HighDesign are cubic B-spline, continuous curves drawn
through a given set of points: to create a spline curve, just click to set the
points that will define the shape of the curve. Double click on the last point to end the curve.
Choose the fill color on the corresponding menu of the Properties bar.
To edit a Spline curve, once it is selected, move the given points with the Arrow tool or with
the pointer and the Spline tool method active.
Revision Cloud: with this method you can create a group made of chains
of connected arcs. You can use this tool to draw a personal set of revision
clouds to be saved as symbols for future uses.

Text
This tool lets you insert multiline texts, rotated labels and annotations into your project. A text block
has its own properties of font face, size, style, color, alignment and a background shape.
To set the properties of new texts, double-click the Text tool icon to open the Text Inspector or
choose the menu item Edit > Inspector > Text...
To change the properties of an existing text block, select the text object and double-click the Text
tool icon or choose Edit > Inspector > Text...
The Text inspector window provides easy access to all the graphic attributes of a text. If no text
object is selected in the drawing, it shows the default values that are applied to all new objects; if
one or more text objects are selected in the drawing, it shows the properties of the last text block in
the selection.

PRO

In HighDesign Professional values and current graphic settings can be saved as presets by

way of the Preset pop-up menu: use this menu to display and select your presets.

43 | Chapter 4 Drawing with HighDesign

The Text Inspector window provides the following options:
A. Preset menu to save current settings or
choose a saved preset;
B. Font face, selectable from a complete list of
the fonts installed on your system;
C. Text size, in any supported measurement
unit;
D. Text style (bold, italic and underline), which
applies to the whole text;
E. Alignment (left, centered, right), in both
multiline texts and single line labels;
F. Character spacing and Line spacing controls;
G. Writing direction options for international
characters and languages.
H. Shapes of the text border, such as plain
paragraph (no border), rectangle, round
rectangle, circle or oval;
I. Color of the shape’s border.

NOTE To set the color of the whole text box, use the colors menu on the Properties Bar.

METHODS:
TEXT BOX: This is the method to create text paragraphs with text styles.
Click to set the base point, drag the pointer to set the width and height of the
text field, exactly as drawing a rectangle, and insert the text in the input box; this box also
supports the “Cut, Copy, Paste and Select All” commands.
The Text Styles bar opens once
you define the text box, providing
the menus and buttons to set the
text style of single words within
the paragraph.
This way you can have a text box
with words of diﬀerent font, size,
color and style. Click outside the
text box field to enter the text paragraph.
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LABEL: this method allows you to insert text labels and paragraphs with given
angles. Diﬀerently from the Text Box method, texts created with this method
can have a single text style.
To create a rotated label, once the text is entered in the field, you can set the base angle by
moving the pointer to rotate the label around the insertion point: click to end or set the given
angle numerically. To create the label without setting the angle, push Command + Return.
To edit the content of a text object, activate the Text tool, select the object and click within the
field: then modify the text; you can also edit the text by double-clicking the object with the
Arrow tool.
To resize a text block, activate the Text tool, select the field and drag one of its angles. Text
blocks only support resizing of width, not height, as the height of the object is calculated on
its width and its contents and style properties.
ANNOTATION: with this method it is possible to add text annotations to the
project with few clicks. The first click defines the start arrow of the annotation
and the second click sets the endpoint and the angle; the horizontal movement of the pointer
and the next click define the landing. Enter the text in the label field as in the previous text
methods.
In the same way as the Rotated Label method, the text of the Annotation can be multi-line
text with a single style for all the paragraph. When used on a drawing object, the annotation
prompts the basic information about that object. Supported object types are hatches,
symbols, walls, columns, doors and windows. For example, annotations added to symbols by
default prompt a caption with the names of the symbol and the current view.

When editing an annotation, hold down the Alt key to switch the side of the label.

Dimensions
Use the Dimensions Tool to insert linear, multiple linear, radial, angular, ordinate and elevation
dimensions.
To set the dimension properties, either double-click the Dimensions tool in the Drawing Tools bar or
choose Edit > Inspector > Dimension to open the Dimension Inspector dialog.
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Dimensions Inspector window

Text pane
A. Preset menu B. Label font C. Text size D. Label text style E. Dimension units F. Label options:
prefix, custom text to use in place of the measure, display units after the measure G. Tolerances
and text size of tolerances, relative to the main label.
Graphics pane
H. Arrowheads and Arrow size in current units I. Display extension lines and graphic settings J.
Label position (middle, inside or outside) and oﬀset from witness line K. Label frame option L.
Orientation of label, horizontal or aligned to the witness line.

PRO

In HighDesign Professional values and current graphic settings of Text and Graphics pane

can be saved as presets via the Preset pop-up menu: use this menu to display and select your
presets.

METHODS:
LINEAR DIMENSIONS: this method is used to insert linear
dimensions between two datum points. The dimension line can

4 6 | C h a p t e r 4 Drawing w i t h H i g h D e s i g n

have a generic angle or can be axis aligned and display the dx or dy distance with absolute
values. To use this tool, click on the datum points and move the pointer to place the
dimension line; if you move vertically or horizontally (following the guide lines that appear on
screen) you create a vertical or horizontal dimension; otherwise, the dimension will be objectaligned.
MULTIPLE LINEAR DIMENSIONS: this method allows you to
insert horizontal or vertical aligned dimensions (dx or dy
distances) of two or more progressive points. Once the first segment is defined, all following
dimensions will respect the first alignment and height.
RADIAL DIMENSIONS: with this method you can get radial
dimensions of arcs and circles.
To create a radial dimension click on a circle / arc and move the pointer inside or outside the
circle to place the dimension; click again to set the end point. A dialog will show you the
available options of the information displayed in the label (radius, diameter, angle and length).
ANGULAR DIMENSIONS: this tool lets you dimension the
angle between two lines: to dimension an angle, click on the
first and on the second line; move the pointer to set the radius and the label position and
click. If you click outside the datum lines the dimension will show the complementary angle.
ORDINATE DIMENSIONS: with this method you can calculate
the perpendicular distance from an origin point. The origin is
identified with the Absolute Origin of axes. Distances along the x- and y-axes to objects to
measure are specified using extension lines, with the distances indicated numerically at their
ends with text labels.
Set the Origin and click on the points to measure: move the
pointer parallel to the X axis to get the Y distance and
parallel to the Y to get the X distance. If you change the
origin, Ordinate dimensions will be updated automatically.

ELEVATION DIMENSIONS: this method can be used to add
elevation dimensions to your project.
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To create elevation dimensions, set the “zero” datum, that is the Absolute Origin, and click on
the points you need to measure. All dimensions will display values relative to the origin; if you
move the origin, all other dimensions will change their values accordingly.
Dimensions can be edited to change their position, distance from the measured object and
placement of the label. With the Dimension Tool active, click one of the extension points and move
the pointer to modify the dimension; if the witness line is horizontal or vertical, the movement will be
direction-constrained.
Click on of the endpoints of the witness line and move the pointer to change its distance from the
extension points.
Click on the control point of the label to edit its placement along the witness line; you can also place
the label outside the dimension: in this case a line will extend from the witness line to the label.
Radial dimensions are associative: edit the measured object to change its position and values; click
one of the vertices of the extension line to change its position and place the label inside or outside
the circle.
Angular dimensions can be edited to modify the radius and the width of the arc and the label
position: click on the arc and move the pointer to edit the radius; click on the vertices to modify the
width and click on the datum point of the label and move to change its position.
Ordinate dimension, that are linked with the origin, can be edited by moving the control points with
both the Arrow tool and the Dimensions tool.
Elevation dimensions can be moved with the Move tool: the measure will be automatically updated
with the new position.
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Walls, Columns, Windows PRO
Use this tool to draw walls, round columns, pillars and insert parametric doors and windows. The
Walls, columns and windows tools are available to HighDesign Professional only.

METHODS:
WALLS are parametric objects, automatically connected on vertices and
edges when intersecting each other and can be edited
at anytime. To set wall attributes, double-click the wall
tool icon or select Edit > Inspector > Wall... to open the
Walls Inspector dialog.

A. Preset menu.
B. Width, in the current unit: if you choose the option to
draw walls of variable width, both input fields are
active.
C. Leading side: three buttons to select the
construction side of the wall (you can also access this
option by clicking the triangle on the Wall button of the
methods).
D. Option to invert the interior and exterior faces of the
wall: the exterior side is highlighted in blue when
drawing and selecting walls.
E. Wall Joints options.
F. Line type.
G. Pen weight.
H. Fill color.
I. Hatch type and color. Hatches inside walls have an
absolute origin.
J. Scale factor of the current hatch.

To draw a wall, click to set its start point, move the cursor and
click again to set its endpoint: walls are connected like polylines.
Walls have their construction side and the “Exterior side”
property, marked with a blue line, to consider when inserting
openings: to change the leading side while drawing, click on the
Option menu close to the last vertex. Press the Alt key to invert
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the exterior side while moving the cursor.
To edit a wall, select it and move, stretch, shorten it with the Arrow tool or change its
parameters numerically via the Object Info palette.
The Tools menu and the contextual menu provide two commands specific for walls: Convert
to Wall and Rebuild Wall.
Convert To Wall transforms the selected lines or polylines into walls with the current settings.
Rebuild Wall regenerates the geometry, intersections and nodes of the selected or clicked
walls.

COLUMNS AND PILLARS: to insert columns and pillars, select the
corresponding method in the Methods bar and open the Inspector to
choose the type of pillar.

Set the base and click once to place the square pillar. As pillars can have any base angle, you
have to click again to set the desired angle.
When the Rectangular pillars option is active, the input fields for width and height are both
enabled.
Round columns require just to enter the diameter and one click for insertion

5 0 | C h a p t e r 4 Drawing w i t h H i g h D e s i g n

DOORS AND WINDOWS: this method allows you to insert parametric
objects within existing walls. Even though these are complete objects,
doors and windows always refer to a wall and cannot be inserted outside a wall; furthermore,
doors and windows are related to the exterior side of the wall.

Casement window and swinging front door in a masonry wall (the
exterior side of the selected wall is highlighted in blue).
To edit and set properties of doors and windows, select Edit > Inspector > Door / Window...
to open the Doors / Windows Inspector dialog. This dialog provides all the options to
customize the opening by choosing the opening type
and all the parameters that can be stored as presets.

Doors and Windows Inspector.
A. Preset menu: save a new preset with the current
settings or load a saved preset.
B. Type pop-up menu: click to select the type of
window or door.
C. Rough Opening is the full extent of the opening in
the structure of the wall, including the casing; Frame
Width is the distance between the jambs.
D. Casing type: click on the thumbnail to select
Masonry or Frame construction method. You can use
the three input fields to set the casing size and the
shape of the door/window jamb.
E. Frame Size is the thickness of the frame; when the
current type is a door, it controls the thickness of the
door.
F. Oﬀset of the frame of the opening from the external
surface of the wall in the current units.
G. Number of sashes: the number of vertical mullions
depends on the number of sashes.
H. Sill display option and dimensions.
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I. Options to display the axis, to open the door/window inside or outside, or to change the
swinging side of doors.
J. Swing angle of swinging doors.
K. Projections of wall edges (none, external side, both sides); Insertion point of the opening,
relative to the click: left, center, right.

To insert a door / window in a wall, select the Walls & Windows tool in the Tools bar; select the
Doors & Windows drawing method in the Methods bar and choose the corresponding
settings; set the position of the opening by clicking on the wall; click the internal / external
area of the wall to choose the opening side. For instance, to insert a door on a horizontal wall,
click on the wall to locate the door, then click in the upper right quarter of the region described
by the cartesian axes to set its opening side.
As you move the cursor over a wall, temporary dimensions show the relative distances of the
opening from the surrounding vertices or joints of the wall. To set and constrain the value of
either dimension, so that the opening is exactly at that distance from a reference point, enter
the value on the keyboard and move the pointer, so as to choose which dimension on either
side of the wall the value applies to. Click to confirm and insert the opening.
While editing the position of a selected door / window with the Object Info pane, the distances
of the opening vertices from the nearest internal or external endpoints or intersections of the
wall are highlighted when the cursor enters the palette (click the small triangles of the palette
to browse through the points of the opening).
Direction and opening side of a door can be changed through the Inspector window: select
the door, open the Inspector and select “Open Inside” or “Swing to opposite side”.

NOTE

Windows are always inserted relative to the external surface of the wall, which is

marked in blue when selected. To change the opening side of a window, you have to select its
wall and invert the interior/exterior sides via the Wall inspector.
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Types of Windows and Doors:
• Simple opening
• Generic window
• Window with simple-line glass
• Casement window
• Swinging door
• Double swinging door
• Bypass sliding door
• Surface sliding
• Double Surface sliding door
• Pocket door
• Double pocket door
• Folding door
• Double folding door

Symbols
The Symbols Tool is a drawing tool which allows you to put in your project entire drawings or
portions of drawings already created and stored in a library with just one click. Using Symbols is a
convenient way for reproducing many times the same group of elements with independent rotation,
mirroring and scale factors.
To edit or set the Symbol Tool properties, select Edit > Inspector > Symbol or double-click the
Symbol Tool icon in the Drawing Tools bar.
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The Symbol inspector dialog provides you with many
options to choose a new symbol and set its attributes.
•The table lists the currently selected library folder: this
folder may contain many sub folders and can be
organized at your choice. Browse through this table to
select the symbol file.
•Once a symbol has been selected, a lists all of its
views shows up if available: select a view from the list
to activate it; double-click its name to change it and
click on the pencil icon to edit the symbol/view (for
custom symbols only).
•The preview box displays a thumbnail of the selected
symbol with the current parameters.
•Symbol geometric parameters are: width, height
(which can resize proportionally), angle (in degrees);
Below the input fields, the Quick transformations
buttons enable the mirroring of the symbol.
•Symbol properties are the fill and color options and
the option to scale the symbol correspondingly to the current drawing scale.
• On the bottom are grouped the buttons to (from left to right) create a new folder, create a new
symbol from selected objects, duplicate the selected symbol, add a new view to an existing
symbol and delete the selected item.
To insert a symbol into the drawing:
1. Open the Symbol Library dialog by choosing Edit > Inspector > Symbol or by double-clicking the
Symbol icon in the Drawing toolbar;
2. Select a symbol in the Folders table and choose one of the available views;
3. Set its size and optional parameters;
4. Click the center or one of the vertices or midpoints of the thumbnail to select the insertion point;
5. Either drag the preview to the drawing or click on the desired point of the drawing.
To create a new symbol, to add a view to a symbol or to edit an existing symbol, are also available
the specific commands on the Tools menu. To learn more about this feature, read “Creating and
Editing Symbols” on chapter 6.
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Viewing Tools
Panning
Use this tool to drag the drawing area and quickly move the current view. To use the Panning Tool
click and drag the mouse pointer.
Double-click the tool icon to set the view to the center of the drawing.
The panning tool can also be temporarily activated with any tool by pressing the space bar on the
keyboard: if you already started a task, for instance drawing a line, the use of the panning tool will
not interfere with the current function.
With a multi-button mouse it is possible to pan the drawing by clicking the middle / wheel button
and dragging the pointer.

Zoom
The Zoom tool allows you to enlarge or reduce the current view of the drawing by zooming in or out.
Click on the start point, then move the pointer and click again the define the rectangular area that
will be zoomed. Hold down the Option key to zoom out.
The zoom factor is inversely proportional to the size of the zoom rectangle, that is, the smaller the
rectangle is, the higher will be the factor.
Double-click the tool icon to set the view factor back to 100% (actual view).
Other zoom commands are grouped under the Drawing > View menu, including “Zoom to Fit”,
“Zoom In” and “Zoom Out”.
Dynamic zoom is enabled by pressing “cmd and +” or “cmd and -” buttons on the keyboard or, with
a multi-button mouse, by rotating the wheel: rotate the wheel forward to zoom in and backward to
zoom out. Trackpad gestures are also supported by the dynamic zoom.

Measure Tool
The Measure tool, to not confuse with the Dimension tool, provides two methods: Line Measure and
Path Measure.
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METHODS:
Line Measure allows you to quickly check linear distances between two objects
of the drawing: to measure a linear distance, activate the tool and the
corresponding method, click to set the start point of the measure line and click to
set the end point. A label displays the distance in the current units. The distance is also
displayed in the Object Info palette.
The Path Measure method enables the measurement of segmented paths. Click
to set the vertices of the path and double-click to end; to edit a vertex, click it and
move the pointer. The label displays the total distance of the path.
Measure lines and paths are only visible and editable when the Measure tool is selected.

PRO

In HighDesign Professional, the Measure tool can be used in the Photogrammetry

environment to measure actual distances directly on the perspective view of the image.

Print Area
This tool allows you to create regions of the drawing to be printed alone, like details of a larger
project. Print areas can have a name, a color and a layer, and they are saved within the project like
any other object. You can decide to hide them during a normal design session by choosing the
menu item Drawing > View > Print Areas. The same command can also be used to show hidden
print areas.
To create a print area, click and move the pointer to draw a rectangle; click to set the area and insert
a name in the input dialog. As you move the pointer, several rectangles show the preset page sizes
in the diﬀerent systems, like ISO and ANSI, and attract the pointer to create a print area of a given
size. To override this feature, hold down the Command key while moving the pointer.
To edit an area, select it and, with the Print Area tool active, click one of its vertices and move the
pointer. To change the name of an area, select it and click on its name label; then insert the new
name in the input dialog.
Once you have created a print area, you can open the Print window and select it from the Print Area
pop-up menu.
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Image
Images in HighDesign can inserted via the Insert menu command, described in Chapter 2,
Inserting an Image, or via the Image inspector by clicking on the empty preview box. Supported file
types are TIFF, JPG, PNG and PDF. Alpha levels present in TIFF and PNG files are preserved.
Images can be moved, resized and rotated, either via the
editing tools, the Object Info pane, or the Image
inspector.
The Image inspector provides the following options:

• Size: the dimensions of the image object in the project,
measured in points, millimeters or inches;

• Print Size: the dimensions of the image as printed on

paper or to PDF. Print size varies according to the image
resolution;

• Image Resolution, in Dots Per Inch.
• Display at screen resolution: when active, the image is
always displayed at the resolution of the screen, which is
typically lower than paper. The visible size of the image is
larger at lower resolutions.

• Transparency: sets the amount of transparency the image is displayed at. Values range from 0%,
totally opaque, to 100%, totally transparent.

• File Format: images are handled like other vector objects and saved in the project file. The internal
format can either be PNG, which preserves the full quality of the image, or JPEG, which
compresses the image and saves file size considerably, but reduces the quality. JPG is very good
for photographic images, but not for images that contain line drawings, such as city maps or
scanned drawings.
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Snap
HighDesign provides automatic grid, object, vertex,
intersection, right-angle / tangent and alignments
snap. Snap is a function that allows you to draw
with the maximum precision by automatically
setting the insertion on datum points of objects or
by joining endpoints of lines and other objects
Snaps can be toggled on and oﬀ through the Snaps
menu on the bottom-left hand side of the main
window in the Input Bar.
The following snap options are available:
• Snap to grid (A): the pointer snaps to grid knots;
• Snap to endpoint (B, C);
• Snap to object (D, E): the pointer recognizes a minimum distance from an object body;
• Snap to intersection (F): all intersections are interpreted as endpoints;
• Snap to right-angle (G): the pointer changes when the current line intersects another with a right
angle;
• Snap to tangent (H): the pointer changes when the current line is tangent to a circle / arc;
• Snap to alignments (I, L): the pointer snaps to two temporary guides. When the pointer snaps to
one endpoint of an object, that location is stored as current origin of the guides; the guides are
displayed when the cursor is on the X-axis or Y-axis of that datum point. The pointer also snaps
to the intersection of the guides: the intersection is highlighted with one point and both the guides
visible. Furthermore, when you place the pointer over one segment, this function stores the angle
of that segment displaying the corresponding parallel and orthogonal guides: when tracing the
line, just place the pointer over one datum point of that segment (endpoints or midpoint) to
display the alignment. To temporarily disable the Snap to alignments, hold the “cmd” key.
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The Snap function is always highlighted by a diﬀerent shape of the pointer, corresponding to the
current snap condition: if the “Play Sounds” option of the Workspace pane of HighDesign
Preferences is active, the snap function is also pointed out by a typical sound.

Drawing Constraints and Input Bar
The Drawing Constraint functions allow you to quickly draw items with some conditions, such as
parallelism, angle constraints or intersections. The Input Fields on the Input Bar allow you to enter
the coordinates of drawing points and the geometric dimensions of the objects, like length and
angle.

Constrained directions
Linear or polygonal graphic objects such as lines and polylines, rotated rectangles, hatches, arcs
and ellipses by radius and diameter, dimensions and walls, can be drawn aligned with one of the
Cartesian Axes or rotated by steps of 15 degrees: to do this, just press the Shift key while moving
the pointer.

Constrained Parallel, Right-Angle and Intersected
These three buttons on the Input Bar provide the Right-Angle and Parallel constraints and the
Intersected condition.
CONSTRAIN PARALLEL (P) and CONSTRAIN RIGHT-ANGLE (R): these conditions can be activated
anytime with any tool or editing function and will aﬀect the direction of the current movement.
To activate the Right-Angle or Parallel condition:
• After the first click of the current operation you are performing, click the button
corresponding to the desired condition or press its keyboard equivalent (P or R);
• Click the reference object, e.g. the line you want to draw perpendicular or parallel to (the
mouse-cursor changes to a pointing hand when on a valid object);
• To cancel a condition, press the Esc key on the keyboard.
CONSTRAIN INTERSECTED: this condition constrains the pointer to intersect the datum line,
extending the line you are drawing to the intersection point, even outside the segment bounds.
To activate this condition, click the button in the Input Bar or press its keyboard equivalent.
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The same result can be achieved by pressing the Command key + click on the datum line while
drawing the line, polygon, wall or hatch/fill.
The snap options and the drawing constraints can also be displayed as grouped in a small
floating window you can move to a convenient position on the screen. To show this option, select
“Snaps” on the Window menu.

Input Fields: Coordinates, Distances, and Angles
The Input fields are grouped together in the middle of the Input Bar: use these fields to enter the
values of constrained coordinates, length and angle of the object you are drawing. The X, Y and L
fields also support additions of partial values.
When you click on one field or use the keyboard shortcut, a visual aid shows up to point the current
constraint out.

In all input fields, values can be entered either as numbers, such as “100”, or as a sum of
numbers, such as “100+20+60”.

X and Y Coordinates
Coordinates in HighDesign are either absolute or relative. Absolute coordinates are calculated from
the global origin point of the drawing, and relative coordinates are calculated from the previous point
of the object.
The insertion point of an object, that is its start point, is always set and viewed in absolute
coordinates, with the X and Y values calculated from the origin of the current sheet. The next point
is relative by default, but you can change it from relative to absolute by clicking the X or Y icon on
the input field.
For example, in a line with points at (20, 20) and (100, 100), the end point is (100, 100) in absolute
coordinates and (80, 80) in relative coordinates.
To set the absolute insertion point:
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• Click on the corresponding input field or press the “X” or “Y” keys on the keyboard;
• Enter the desired X or Y distance from the Origin;
• Press Return to confirm.
To set the relative end point:

• Click on the coordinates fields or press the “X” or “Y” keys on the keyboard;
• Enter the desired dx or dy distance from the start point;
• Press Return to confirm.
You can change from relative to absolute coordinates and vice-versa by clicking the X or Y icon on
the input field or using the corresponding key shortcuts.

Constrained Length

You can constrain a segment, line or radius to a fixed length after you have set the start point. In
HighDesign, there are two methods for constraining a length that can be used interchangeably.

61 | Chapter 4 Drawing with HighDesign

A. Define direction, set length.

B. Define length, set direction.

• After the insertion point is set, move the • Click on the Length field or push the “L” key
pointer at the desired angle of the next point;
on the keyboard;
• Enter the desired length, either as a total • Enter the desired length;
length or as a sum of partial values;
• Press Return to confirm;
• Press Return to confirm;
• Move the pointer to set the angle of the
vector.

Constrained Angle
To constrain the pointer movement to a fixed angle:
• Click on the “A” field (Angle) or push the “A” key on the keyboard;
• Enter the desired angle value (in degrees);
• Press Return to confirm;
• Move the pointer to set the destination length.

Relative Angle
It is possible to constrain the pointer to a relative angle to a reference direction:
• Click on the “A” field or push the “A” key on the keyboard;
• Enter the desired angle value (do not push the “Enter” key);
• Click on the reference direction (line, polyline segment or wall);
• Move the pointer to set the destination length.

Constrained Distance
To set the distance of the insertion/start point of an object from a datum point, type the value, push
Enter and click on the datum point; the distance is now displayed as a radius from the datum point:
click to set the insertion/start point of the object.

Activating drawing constraints by using the TAB key
Drawing constraints for X and Y coordinates, Length and Angle can also be activated by pressing
the Tab key on the keyboard. When you first push that key it activates the X constraint; then, in
order, Y, L, A. Activating the Y constraint stores any values inserted into the X field, so to make it
easier to set the coordinates of a point.
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Setting and Editing Properties
Most of the properties common to all object types can be set and changed in the Properties Bar.
Properties that are shared among most object types are: layer, pen color, fill color, pen line types,
start and end markers, pen weight.
To set the properties for new items, make sure no object is selected and then use the controls on
the Properties bar.
To edit the properties of an object, select it and then change the corresponding values.

PRO

In HighDesign Professional you can save properties and create custom styles: to learn

more about Styles, read the Styles paragraph in Chapter 8 Windows and Palettes.

Layers
Use the Layers pop-up menu in the Properties bar of the main
window to set the current layer and change layer to selected
items. To the left of the layer name there are the icons of the color,
visibility and lock attributes: click them to edit those attributes.
To change the layer of an item, select it and choose the new layer
from the Layers pop-up menu. Through this menu it is also
possible to open the Layers Manager pane of the Drawing
Manager window, also available on the Organize menu.

Pen Color
Use the Pen Color pop-up menu to select the current pen color or
change the color of selected items. Pen color controls the color of
the outline of objects.
You can choose a pen color from a palette of 256 indexed colors;
use the color of the current layer with the By Layer option; set a
contrast color; or set no color at all. When the “By-Layer” option is
activated, the current color is that of the current layer. With the
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“Color by Contrast” option the color is automatically set on screen as white with dark backgrounds
or black with light backgrounds (invariably black on printouts).

Fill Color
The Fill Color pop-up menu controls the options for filling a shape
with color. The button is active only for objects with the fill property,
like polylines, polygons, fills, arcs, circles and ellipses and walls.
Available options are:

•The palette of 256 indexed colors with adjustable opacity, varying
from 0%, fully transparent, to 100%, fully opaque.
•No color button.
•System color picker.
•Gradient. Use this button to switch from solid color to gradient.

Gradient Editor
The gradient button on the Fill menu opens the
Gradient Editor. A gradient is a fill that varies its color
from a start color to an end color, with variable
opacity. Available gradient types are linear (or axial)
and radial, and can be activated through the buttons
on the top left hand corner of the window.
Next to the type buttons is the Invert Colors button,
which inverts the colors in the gradient slider.
The Angle slider and field control the angle between the start and end points of the gradient.
The color slider controls the colors and their locations along the axis. Click a color to open the
color menu and adjust its opacity; click on the slider to add a color; drag a color along the slider to
change its location; drag the color vertically to remove it.
By default, changes are visible in real time. Depending on the complexity of the project, you can
click the Show Preview checkbox to disable the live preview.
The geometry of a gradient, that is position of the end points and radius of the circles, can be edited
by selecting an object with a gradient and adjusting the points on screen.
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A linear gradient is an interpolation of color that varies along a line between two defined points.
When you select an object with a linear gradient, a line with two endpoints marks the linear gradient.
You can edit each point and adjust the gradient as needed.
A radial gradient is a fill that varies along an axis between two circles. In a selected object, a radial
gradient is displayed with two circles, typically of diﬀerent sizes. The second circle, corresponding
to the end color, must always be contained inside the first circle.
Start points are marked with a square handle, and end points with a round handle.

NOTE Due to the underlying graphics engine, gradient colors with varying opacity cannot be
printed or saved as PDF. On print or PDF, such gradients are captured with an opacity value of
100%. Transparent gradients can be exported to an image format such as TIFF, PNG or JPEG.
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Line Types
Use the Linetype pop-up menu to set the current line type or edit selected items (when applicable).
This pop-up menu lists all currently loaded line-types, each with its own index number.
The Linetype menu also provides the option to open the Linetype Manager pane of the Drawing
Manager window to manage existing linetypes or to create new ones.

Arrowheads and Markers
Object vertices, such as lines, polygons, ovals, etc., can have arrows and
other markers.
To set or edit the current object marker, use the two marker pop-up menus:
the left one controls the start point of an object (Start arrow), and the right one
controls end points (End arrow).
A slider on the bottom of the menu allows you to set the size of the
arrowhead.

Pen Weights
Use this pop-up menu to set and edit the current pen weight from a list of 22 diﬀerent values,
expressed in millimeters.
To change an item’s weight, select it and choose the new weight from the menu.
Because of the resolution of the screen (72 dpi), pen weights cannot be displayed on screen exactly
as they look on printouts; when the Actual (print size) Pen Weights mode is on, HighDesign displays
the diﬀerent pens on screen with an approximation to their real print size. When the Bitmap mode is
active, pen weights are displayed with a simple progressive pixel size.
To change the way pen weights are displayed on screen, open the HighDesign Preferences window,
select the Drawing pane and choose one of the three options available for pen weights or click the
button on the lower right hand side of the main window.
In printouts with low quality paper, pen weights may be a bit diﬀerent from those chosen on the
menu. The optimal print resolution is 600 dpi on high quality paper.
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Object Properties
When an object has complex properties, such as wall widths or hatch types, either select Edit >
Inspector > --object/tool-- or, when available, double-click its icon in the Drawing Tools bar to open
its Properties pane. You can also access the Properties pane via the radial menu or through the
button in the Object Info palette.
Tools Inspector panes are available for the following objects and for their methods (if available):
• Text- font face and style; alignment; text block graphic appearance.
• Dimensions- text label style, contents and position; witness line and arrowheads style.
• Walls- width; leading side; edges style; fill and hatch.
• Pillars and columns- size, edges style; fill and hatch.
• Windows- saved settings; type; casing; sizes; insertion point.
• Hatches and Fills- hatch type, orientation and color; edges; fill color and transparency.
• Symbols- symbol file and view selection; size; angle; colors; object data.
• Images- dimensions; print size; resolution; transparency.
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5. Editing a Project

Chapter 5: Editing a Project

▫ Edit Menu
▫ Drawing Menu
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Edit Menu
The Edit menu is commonly used for standard commands like undoing and redoing an operation;
cut, copy, paste and clear; selecting; searching function; arranging and aligning items. It also
provides the option to open the Tool Inspector window, already described in the previous chapter.

Undo / Redo an operation
Most operations in HighDesign can be undone (and redone) up to 300 steps back, thus giving you
the maximum freedom in experimenting.
“Undo” and “Redo” apply to the following actions:
• Creation of new items (e.g. new Line, new bézier, etc.)
• Deletion of one or more selected items
• Modification of selected items (e.g. extend, modify, trim, drag, etc.)
• Complex operations (e.g. fillet, chamfer, paste, etc.)

Suspend Undo
This option is provided mainly for use with slower computers. Some actions may require more
memory and speed than others, so that it would be helpful to pause the Undo engine for that action.
Suspending the Undo engine is an option to gain speed and keep memory as free as possible in
particular situations.

Cut, Copy, Paste and Delete
These are standard functions you find in all programs and provide some simple yet useful actions:
• Cut (Command+X) means that selected items will be deleted from the drawing and put in memory
for later use;
• Copy (Command+C) means copying the selected items to memory, without removing them from
the project;
• Paste (Command+V) lets you insert items stored in memory. This command shows a dialog with
options about the location of the pasted items and the layer to set.
• Delete is used to erase selected items from a project.
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Selection
The Edit menu includes commands to quickly select items with some conditions. Apart from the
“Select All Sheets” command, all selection functions apply to the current sheet.
• “Select All Sheets” selects all elements on all sheets;
• “Select All” command selects all the elements on the current sheet;
• “Select Current Layer” to select all the objects with the current layer;
• “Select All <object type>...” selects all the elements on the current sheet of the same type as the
currently selected drawing tool;
• “Invert Selection” selects all the elements and deselects those that were already selected;
• “Deselect” deselects all the currently selected items.
Drawing items can be selected either via the Arrow tool or by pressing the Shift key and clicking the
item or clicking with the right button of the mouse. See also “Arrow and Selection” paragraph on
chapter 4.

Search Functions: the “Find” command
To search items within a project select Edit > Find... to open the
“Find” window.
The Find dialog lets you search items within the current sheet
setting criteria to reduce the scope of the function. The conditions
you can set are managed by required criteria and by optional
criteria.
Required criteria:
A. Object Type: push the button corresponding to the object type
you want to find.
B. Sheet PRO: select the sheet within which search items.
Optional criteria:
C. Layer: the layer to which the items belong;
D. Pen Color: edge color of the objects to find;
E. Linetype: edge line type of the items to find;
F. Weight: pen weight of the items to find;
G. Text: search for all occurrences of the text in the drawing;
H. Style: search items with a style;
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I. You have three options: select all the items matching the active criteria (“Find All”); select
only one matching item (“Find Next”). By checking the “Zoom To Selection” option you can
have the page automatically scroll to center the view to the selection.

Changing Display Order of Items
Drawing objects are displayed to screen (and print) with the creation order: the first item created is
behind all others. If you place an opaque fill over other items, it will cover everything behind it.
It is possible to change this order by sending back or to the front the selected items by using the
options in the Arrange sub menu of the Edit Menu:
• “Bring to Front” sends the selected item to the front of all other items; if the selection contains
two or more items, they are moved with their internal order;
• “Bring Forward” moves the selected items up one position;
• “Send Backward” moves the selected items down one position;
• “Send to Back” moves the selected items to the back of all other items.

Aligning Objects
Selected items can be aligned via the Align Objects sub menu: “Left Margin / Center in Column /
Right Margin” commands and “Top Margin / Middle in Row / Bottom Margin” options array items
taking the bounds of the selection or the midpoints of the selection as reference.

Functions of the Drawing Menu
Many of the following functions are also available as icons in the Edit Tool Bar for a quicker use.

Drawing Scale
This menu item opens the Drawing Scale dialog: you can set a new drawing scale for the current
sheet either by choosing one from the pop-up menu or by entering a value by hand. Changing the
drawing scale resizes the drawing, so you may want to uncheck the Scale texts checkbox if you
want to keep texts and annotations at their current size.

PRO

HighDesign Pro adds an option to apply the change to all sheets.
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View
This item is a sub menu that provides commands to change zoom and options of the current view:
• Previous View: sets zoom factor and view center back to their previous state. This command can
also be invoked via the radial menu or via the shortcut “<“ + Click with any tool;
• Redraw: forces the view to redraw its content; this is usually done automatically, but this
command can be useful when the project contains many items;
• Zoom To Fit: enlarges or reduces the current view factor to fit the whole sheet to the portion of
drawing space currently visible;
• Center View: centers the current view to the center of the sheet;
• Zoom In/Zoom Out: enlarge or reduce the view by a factor of 2;
• Show/Hide Grid: toggles the grid display;
• Show/Hide Construction Lines;
• Show/Hide Print Areas: if set, print areas are not visible on screen, but still available in the Print
Preview window;
• Anti-alias: switches real-time anti-aliasing on and oﬀ. Anti-aliasing is a technique used to render
high-resolution objects at a lower resolution by smoothing the edges. Anti-aliasing can decrease
the redraw speed in large projects.

Move
Use this function to move selected items. Choose Drawing > Move, then click to set a start point,
move the pointer and click again to set direction and oﬀset of the translation.
This function is also available through the Arrow tool: activate the tool, then click on the outline of
selected items, i.e. not on a vertex, move and click to set the end point.
Another convenient way of moving selected item is nudging: use the arrow key (with or without the
Shift key according to the preferences set in the Preferences dialog) to move the selected items one
pixel horizontally or vertically. You can press the Option key to speed up the movement by a factor
of 10.

Duplicate
This function creates a copy of the selected items with a defined oﬀset. To use this tool, select the
items you want to duplicate; click to set the start point; move the cursor and click to set direction
and oﬀset of the movement.
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The Duplicate function can also be activated by the Arrow tool by pressing the Option key while
moving selected items.
Hold down the Command key to make multiple copies of the same selection in one session.

Linear Multiply/Distribute
Just as the Duplicate command, this function creates a number of copies of the selected items.
The menu item Drawing > Multiply opens the input dialog you can use to enter the number of copies
of the selected objects and select the options to multiply the items with an increment or distribute
them over a distance.
To create copies with an increment (Multiply), click the start point, move the pointer and click again
on the end point to set the increment between the copies.
To distribute copies over a distance, click the start point, move the pointer and click again to set the
distance between the first and the last copy.

The Multiply/Distribute dialog can be used via the keyboard: the Up and Down arrow keys
control the number of copies; Command + Up/Down arrow controls the option buttons.

Polar Multiply/Distribute
Use this tool to create multiple copies of selected objects along a circular arc. The menu item
Drawing > Polar Multiply opens the input dialog used to enter the number of copies and select
between increment and distribute.
To multiply copies of the selected objects with an increment, click to set the center of rotation (the
center of the arc), then click to set the reference point, move the pointer and move again to set the
end point of the increment between the first and the second copy.
To distribute copies, click to set the center of rotation, then click to set the reference point, move the
pointer and click again to set the distance between the first and the last copy.

The Polar Multiply/Distribute dialog can be used via the keyboard: the Up and Down arrow
keys control the number of copies; Command + Up/Down arrow controls the option buttons.
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Rotate
This function lets you rotate selected items around a central point and by an angle you define
graphically.
To use the Rotate tool:
1. Select the objects you want to rotate.
2. Choose Drawing > Rotate.
3. Click to set the center of the rotation.
4. Click to set the start angle.
5. Move the pointer and click again to define the rotation angle.
You can also enter a rotation angle value by pressing the “A” key on the keyboard between steps 4
and 5.

Rotate by Angle
Use this tool to rotate the selected objects in
real time. The center of the rotation can
absolute, which is the midpoint of the
bounding box of the selection, or the center of
the object, which rotates each object around
its own center.
To use the Rotate by Angle tool:
1. Select the items you want to rotate.
2. Choose Drawing > Rotation Angle.
3. Enter a value (in degrees) or use the angular
slider.
4. Push “OK” to apply the rotation or “Cancel”
to cancel this action.

74 | Chapter 5 Editing a Drawing

Mirror
This command transforms objects by mirroring the selection around an arbitrary axis:
1. Select the items
2. Choose Drawing > Mirror
3. Click to set the start point of the axis
4. Move and click again to set the direction of the mirroring axis.

Mirror a Copy
Just as Mirror, this function creates a mirrored copy of the selected items. The procedure is the
same as the “Mirror” command described above.

Stretch
Use this command to pull and resize the objects within the selection rectangle: items which are
entirely within the selection rectangle will be moved whereas all other objects will be resized. Arcs,
circles, ellipses, text blocks, doors/windows and symbols will be rigidly dragged with no change of
shape.
To stretch items:
1. Select the Stretch command;
2. Define the selection rectangle to include the items to stretch in the same manner as Selection
Arrow;
3. Click on the start point of movement and on the destination point;
4. Alternatively, click on the start point, push the L key to input the length and, if needed, push the
A key to define the angle.

Extrude
The Extrude function makes a copy of the selected items with an oﬀset
and builds all the connection lines between the source items and the new
ones: for instance, the extrude function applied to a polygon generates a
“solid looking” shape. This function does not create a 3D object.
To use the Extrude function, select the items, choose Drawing > Extrude,
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click on a start point, move the pointer and click again to set direction and oﬀset of extrusion.

Mark Intersections
This function finds all intersection points between two selected items. Supported intersections are:
• Line - Line;
• Line - Polygon;
• Line - Freehand line;
• Line - Bézier Curve (approximated);
• Line - Arc / Circle;
• Line - Ellipse (approximated)
• Polygon - Polygon;
• Freehand line - Freehand line;
• Bézier Curve - Bézier Curve (approximated);
Select one object, choose Drawing > Find Intersection and click on the destination object.

Join
This command extends two selected lines or walls to their point of intersection: if the lines did not
intersect, they are extended; if they intersected each other, the functions shortens them to the point
of intersection.
This command cannot be applied to parallel lines.

Extend
This function extends the selected lines (either by lengthening or shortening) to their intersection
point with another object. Supported types are:
• Construction line
• Line
• Polygon
• Rectangle
• Freehand line
• Bézier curve
• Arc / circle
• Wall
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Select the lines you want to extend, choose Drawing > Extend and click on the destination object.
The Extend command applies to walls too, extending them only to a reference line or construction
line. To quit this tool press the Esc key.

Split
This function splits into segments lines intersecting other lines, polylines, rectangles, hatches, arcs,
circles, freehands and bezier curves:
1. Select the line you want to split
2. Choose Drawing > Split
3. Click on the intersecting object.

Trim
The Trim function is a multipurpose function
designed to delete linear or curved segments or
parts. It applies to single segments without
intersections with other objects as well as to
segments intersected by other objects.
Segments without intersections
Activate the tool and click on the segment to delete:
if the trimmed segment belonged to a rectangle or polygon, the remaining segments are turned into
polylines.
Segments intersecting other objects
Activate Trim and click on the segment or part of segment to delete: use this tool to clear a drawing
and cut segments, arcs and curves between intersections or extending oﬀ an edge with just a click.
To apply it:
•

Choose “Drawing” menu > “Trim” or click on the corresponding icon of the Edit Tool Bar;

•

A visual aid highlights the segments under the pointer (1);

•

Click the parts of the objects you want to trim;

•

All segments and portions of arcs between intersections or extending oﬀ the edge will be deleted
(2);

•

Click an empty region to quit this command or press the Esc key.
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You can also activate the Trim command by holding down the Backspace or Canc keys on the
keyboard and clicking the object, or by clicking with the eraser tip of a graphic pen. No selection is
required to use this function.

Divide Into...
This command is used to divide the selected line into the number of equal segments you specify in
the Divide Into dialog. This dialog lets you also choose whether divide the line with datum points or
actually create segments.

The Divide Into dialog can be used via the keyboard: the Up and Down arrow keys control the
number of divisions; Command + Up/Down arrow controls the option buttons.

Break
This tool allows you to define a segment that will be subtracted from a selected line. Select Drawing
> Break, click on a line to set the first point of the segment and click again to set the endpoint.

Change Length
It is possible to change the length of a selected line through the Change Length command: select a
line, choose Drawing > Change Length or press the L key and enter the new length; click on the half
to lengthen or shorten.

Copy Properties
With this command all the properties of the selected item are copied and stored for later use. This
function applies to layer, color, line-type, weight and arrowheads. Copied properties can then be
applied to other items of the drawing.
This tool can also be used via a keyboard equivalent: Option-click an item to activate it.

Paste Properties
This command lets you apply previously copied properties to all the items you click on. When the
pointer is over an item the cursor changes to a paint bucket: click to apply the properties to that
item. Click in a void region to quit the Paste Properties tool.
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This tool can also be used via a keyboard equivalent: Command-Option-click an item to activate it.

Project Properties
This menu item opens the sub menu with the options to open the corresponding panes of the
Project Properties window. It is a convenient way of accessing individual project settings.
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6. Advanced Tools

Chapter 6: Advanced Tools

▫ Photogrammetry
▫ Render
▫ Adjust Image
▫ Advanced drawing tools
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Photogrammetry PRO
Introduction
HighDesign Professional provides a powerful, single-image photogrammetry tool to obtain the
actual projection of the architectonic elements captured in a picture: this function can be used for
surveys of architectural façades and any planar surface and it only needs a normal camera and two
measures. No specific equipment nor knowledge is required.
Photogrammetry in HighDesign oﬀers two methods:

• Image Correction: transforms the original image by rectifying the perspective deformation
• Perspective Tracing: creates a corrected projection by tracing the elements in the image after
the internal geometry of the image has been set up. All projections are vector-based.

Here are some requirements and suggestions to get the best results:
• The image must include at least two horizontal and two vertical items (e.g. a door, a window, wall
bricks) and, if available but not strictly required, two items with the third dimension. These
requirements are the only really needed to use the photogrammetry tool in HighDesign.
• If possible, avoid too angled views because the projection could be deformed on the edges of the
image;
• For the same reason as above, avoid fisheye lenses (<28 mm);
• The image should include at least one horizontal and one vertical dimension; however, if you do
not have those dimension, you can set up the projection with any dimension and later resize the
resulting drawing.

Picture of a building in Venice showing a clear internal geometry
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As a rule of thumb, make sure the image includes some reference items and it has not been clipped
or deformed. When the third direction (depth) is not available, the internal geometry of the view
relies on the diagonals of the picture’s rectangle, hence the importance of preserving the original
shape of the picture.

Setting Required Data
The setup process is very simple and it does not require any specific knowledge.
To start a photogrammetry, select Tools > Photogrammetry. HighDesign switches to the
Photogrammetry workspace, with the Photogrammetry setup window, a gray background and a
limited set of drawing tools:
• Arrow;
• Construction objects;
• Lines;
• Polylines with straight segments;
• Hatches;
• Curves;
• Viewing tools (Panning, Zoom and Measure).
STEP 1: select the image
Push the “Choose...” button and select the image file to open. Supported file types are: TIFF, PNG,
JPEG.
Click the “Next” button: the image is now displayed on screen and the Photogrammetry setup
window changes.
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STEP 2: define the internal geometry
Once the image has been opened, select the
geometrical type from the buttons:
1. All three directions X, Y and Z are visible in the
image: there are at least two horizontal lines, two
vertical and two for depth;
2. Two directions X, Y are visible. The image shows at
least two horizontal lines and two vertical, but no depth
line is visible; this type includes pictures taken with the
lens parallel to the surface and scans of plans.
This dialog provides a step by step process to set the required data: the field to enter the Focal
Length of the used lens, if known, is optional.

In this case we selected the first option, with the depth lines clearly visible in the picture. A square
grid and two blue depth lines are displayed over the picture. The procedure is the following:
1. Drag the grid by the handles on its vertices to match the horizontal and vertical reference lines on
the picture like sills, jambs of doors and windows and frames;
2. Drag the two blue depth lines by their endpoints to match the depth reference lines on the
picture;
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3. You can adjust the grid and the depth lines keeping in mind that usually lines far from the center
of the picture have a deformation depending on the quality and focal length of the used lens;
4. Push the “Next” button to jump to the next step of setup.
STEP 3: define the known measures
Two lines, one green vertical and one red horizontal, are displayed over the picture. These lines,
drawn in the perspectival view corresponding with the internal geometry of the picture, will be
utilized to enter the two known measures.
1. Drag the vertical line over the known dimension, in this case the jamb of the arched door, and
stretch/shorten it by the endpoints till it matches the known object: enter the known vertical
measure in the corresponding field of the setup floating window and select the drawing units.
2. Drag the horizontal line over the known object, the sill of the door, adjust it till it matches the
known dimension and enter the actual measure in the corresponding field and set the drawing
scale of the projection.
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STEP 4: choose mode of projection
The setup is now complete and it is possible to
choose the mode of projection between image
deformation and vector projection. By choosing the
image deformation the image will be stretched to
correct the perspective deformation and match the
given proportions: the resulting image then could
have to be resized to fit the known measures.

The second option, “Trace and Project”, consists in tracing all the objects of the image you wish to
survey to get the projection at the desired drawing scale.

Drawing and Viewing Projected Items
As already mentioned, the workspace of the Photogrammetry tool provides a limited set of drawing
tools and three Sheets are listed in the Sidebar: “Sheet 1”, the sheet created by default when you
launch HighDesign; “Photogrammetry”, which stores the image and all the setup data and this is the
sheet you use to trace all the objects to project; “Projection”, which is displayed as a floating
window when you are on sheet “Photogrammetry”. Also, this environment has the following
characteristics:
• Directions are constrained to vanishing points; holding down the Shift key while drawing or
tracing lines, the directions are constrained to the closer vanishing point, vertical or horizontal.
• The Projection window displays the result of all projections, that is, all the items drawn within the
Photogrammetry environment are projected in real time at the drawing scale previously set.
The “Projection” sheet, as all HighDesign sheets, can be used to draw, edit, save and export the
projection like a separate drawing.
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Example of a photogrammetric projection.

Photogrammetry Items of the Tools menu
These commands are used within the Photogrammetry tool and allow you to manage some
important functions:
• “Photogrammetry”: used to start a new photogrammetric projection or to resume the current one.
• “Reset Photogrammetry”: clears all settings (geometry and known dimensions) and brings the
photogrammetry process back to the setup step; the setup window opens again and all projected
items are removed. Please pay attention when using this command as it’s not undoable.
• “Exit Photogrammetry”: hides the picture from the project and pauses the Photogrammetry
environment switching the workspace to Project. Items drawn to the current sheet are not
deleted; select “Photogrammetry” to resume the photogrammetry.

86 | Chapter 6. Advanced Tools

Render PRO
Render is a rendering tool that creates high-quality images of your project with varying eﬀects of
background, pen and fill colors, border and margins, watermark and adjustable size and resolution.
This tool not only applies anti-aliasing to object edges, but it also allows customizable print size and
image resolution and provides background options, frames and color eﬀects to make high impact
presentations of your projects. The result is an image that can be exported into any of the supported
graphic file formats. To set all options, select Tools > Render to open the image settings dialog.

Setting Image Options
Use this dialog to set the visual eﬀects and options
to create an illustration.
A. Image eﬀects: click to show the graphic options.
B. Border: option to display a border, color and
thickness of the margin.
C. Watermark: options to add a digital signature or
watermark to the image.
D. Image size: options to set the image resolution
and size.
E. Preview of the resulting image.
F. Buttons to save the current settings as a new
theme or to delete the selected theme.
G. List of loaded themes.

Once all the settings are done, if you wish to save
the current settings as a new theme for future use,
just push the “+” button close to the themes menu to
see it listed on the menu with the desired name.
Click “Ok” to confirm and open a new window displaying the resulting image or “Cancel” to dismiss
this dialog.

Image Eﬀects
The options to apply graphic eﬀects to the image include:
• Background:
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‣ By Project: sets the background to the same color as used in the main project window;
‣ Plain Color: use the button to select the color;
‣ Horizontal Gradient: select left and right colors of the gradient;
‣ Vertical Gradient: select upper and lower colors of the gradient;
‣ Image, tiled: draws an image as background; pictures smaller than the destination image
are tiled; select the image from disk;
‣ Image, resized: draws an image as background scaling it to fit the destination image.
Images are scaled non-proportionally; select the image from disk.
• Drawing Color:
‣ By project: keeps the original colors of the drawing;
‣ Custom color: choose the color on the pop-up menu.
• Fill Color:
‣ None;
‣ By Project;
‣ Monochromatic: choose the color on the pop-up menu;
‣ Grayscale;
‣ Sepia.
• Linetype: select the linetype from the loaded list.

Watermark
The Watermark feature of the “Render” tool allows you to add a text watermark to the image: the
text style options include Font, size, text style (bold, italic, underline) and color. Through a menu it is
possible to set the position of the watermark within the image.

Image Size options
In this pane are grouped all the options to set the desired format, size and resolution of the resulting
image.
• Preset: choose the size that best fits your needs from the many standard formats in the menu;
• Pixel Size: use the fields to enter your custom image size in pixels: click the icon to lock the
desired ratio;
• Resolution: set a resolution of 72 dpi for Web publishing or presentations, whereas 300 dpi or
higher resolutions are best for print output;
• Print Size: you can set width and height of the printout, using the menu on the right to set the
units.
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Exporting Images
The resulting image is displayed on a new window which provides some buttons, including the
zoom buttons: press the “Save” button to export the image as a TIFF, PNG or JPEG file or the
“Copy” button to copy the image to the clipboard.
You can also drag and drop the image on the main project window to insert it in the current sheet.

Sample illustration.

Adjust Image PRO
HighDesign lets you insert images into a project and treat them as any other vector object: just as
you can change color and line type to an object, you can edit images as well.
It happens quite often to have the need of adjusting the brightness, contrast, levels of color of an
image to be used for a photogrammetric projection or as a background for a drawing: HighDesign
provides an integrated image editing module to quickly apply many image enhancements.
This tool allows to change the whole image or just a portion of it by applying pixel transformations
and filters. If you need to rotate or resize an image, use the standard Drawing > Rotate or Tools >
Resize functions.
To change size on screen, print size, resolution and transparency of the selected image, use the
Image Inspector on the Edit > Inspector menu.
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Applying Filters to an Image
Select an image, then choose Tools > Adjust Image: a
window opens with all the controls to edit the selected
image.
The Adjust Image dialog shows the preview of the image
on the top. The controls are grouped as transformation
buttons, advanced filters buttons and the sliders for
brightness, contrast and saturation. Available options are:
• Transform:
‣ Mirror Horizontal, mirrors the image horizontally on its
Y axis;
‣ Mirror Vertical, mirrors the image vertically on its X
axis;
‣ Crop, trims the borders of the image leaving the
selected area only;
• Focus and Colors:
‣ Grayscale, changes all colors to gray;
‣ Invert, inverts all colors from positive to negative and
vice versa;
‣ Sharpen, enhances the contrast on the edges;
‣ Blur, smoothes the image;
• Brightness, controls the amount of light in the image;
• Contrast, adjusts the contrast between colors;
• Saturation, enhances the color saturation.
To apply a filter, push the corresponding button or move the slider. Sharpen and blur filters can be
applied multiple times. Any filter you apply, which you can preview in the thumbnail, is stored in a
temporary image until you push the “Apply” button, which applies all filters in queue to the main
image, while the “Cancel” button clears the filter queue.
The “Revert Image” button, on the lower left hand corner of the window, clears all applied filters
from the image.
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Advanced Drawing Tools
Fillet / Chamfer
These commands allow to join two segments, lines or polylines, by an arc with a given radius, or by
a chord with a given length. There are two ways to use these tools:

ANALYTIC:
1.Select two non parallel segments;
2.Choose Tools > Fillet or Tools > Chamfer or click on the
corresponding icon of the tool bar;
3.A text field shows up near the tool icon: insert the value of the
radius or the length of the chord and push Enter.

GRAPHIC:
1. Select two segments;
2. Choose Tools > Fillet or Tools > Chamfer or click on the corresponding icon of the tool bar;
3. Click on the white handle of the radius/chord and move the pointer along the constrained
direction perpendicular to the radius/chord to resize its length;
4. Click again to confirm.

When applied to polylines, you can change the vertex to modify by placing the cursor over the
vertex and wait for a second until the preview updates.

Oﬀset
This tool is used to create concentric duplicates of linear
objects (lines, polygons, rectangles, polylines, freehands,
arcs, circles and ellipses) at a given distance.
To activate the command, select the objects and go to
Tools > Oﬀset: enter the distance in the text field showing
up near the tool icon, then click on the white handle and
move the pointer to choose the side you want to place the
duplicate on.
Click on the other objects if you want to apply the command with the current settings to other items.
Press ESC to conclude the command.
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Explode
Most of the drawing objects, such as polygons, freehand lines, Bézier curves, arcs and circles,
ellipses, hatched polygons, symbols, walls, windows and columns, can be converted to simpler
items by the Explode command.
Select the items you want to simplify and choose Tools > Explode: all the selected items are
converted to lines and the source object is deleted. Symbols are converted to their base items.

Resize Drawing
This is the tool used to resize the drawing on the current sheet or the selected items by a
proportional or an asymmetric ratio. Select Tools > Resize Drawing to open the dialog and set the
values.
If there are selected objects, the changes are applied to the selection only: if the “Resize all drawing
by selection” option is active, the changes are applied to the whole drawing.

Resize Drawing dialog
Symmetrical scaling: lock the fields to keep the
proportions and scale the elements by the same
factor in both directions; values above 100%
enlarge, values from 1 through 99% reduce;
Asymmetrical scaling: unlock the fields to enter
different factors for the horizontal and the vertical
directions;
Referenced scaling: select the actual units on the
menu and enter the new values.
The Current values display the selection bounding
box: if no objects are selected, these display the size of the whole drawing.
Check the “Resize all drawing by selection” option to apply the changes to the whole drawing on
the current sheet.
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Creating and Editing Symbols
The “New Symbol” and the “Edit Symbol” functions, when activated, switch to a diﬀerent
workspace with a limited set of tools: in this environment you can draw, modify and save symbols
and symbol views.
You can either create a new symbol from scratch or create a new symbol from the selection: in this
case you can also activate this function through the Radial Menu for a quicker workflow. This way
the selected objects are now visible in the “Edit Symbol” environment whereas all the other
elements of the drawing are hidden.
To Create a new symbol:
1. Select “New Symbol” on the Tools
menu;
2. The Environment turns to the “Edit
Symbol” context with a limited set of
tools and a dialog opens;
3. Draw the symbol;
4. Type the symbol name;
5. Select the destination folder through
the folder button;
6. Use the “+” button to add a new view.
7. Type the view name;
8. Press the “Save” button on the dialog.
To edit a symbol you can click on the Edit button of the selected symbol on the Inspector window,
or select the symbol on the drawing and either choose “Edit Symbol” on the Tools menu or use the
Radial Menu.
The “Edit Symbol” workspace opens and you can modify the symbol, add views to the symbol by
pushing the “+” button of the dialog or delete views through the “-” button. By pushing the “Save”
button, the environment turns back to “Drawing”. Changes made to a symbol are immediately
visible in all the symbol duplicates of the drawing.
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Apply Hatch
This command applies a hatch or fill to the region described by the selected items. Supported
boundary items are:
• Lines connected by their vertices (“segmented lines”);
• Polylines;
• Polygons;
• Freehand lines;
• Bézier curves;
• Arcs;
• Circles;
• Ellipses
To use this tool, select the boundary items, then choose Tools > Apply Hatch: a new fill/hatch is
created with the current settings of the “Hatches and Fills” tool.

Calculate Area
This function calculates the area of a region enclosed by the selected items. Supported boundaries
are:
• Lines connected by their vertices (“segmented lines”);
• Polylines;
• Polygons;
• Polygons;
• Freehand lines;
• Bézier curves;
• Circles, arcs, ellipses.
To use this command, select the boundary items, then choose Tools > Calculate Area: a new text
label displaying the area of the region in the current units is created in the center of the selection.

Calculate Center of Mass
The function “Find Center of Mass” calculates the position of the center of mass of the selected
polygons, closed polylines or hatches. To calculate the center of mass of curved regions like circles
or béziers, you can explode them and then apply this command to the selected lines.
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Tangents to Two Circles
This tool finds four points that define the lines tangent to two circles. To use this command, select
two circles or circular arcs, then choose Tools > Tangents To Two Circles.

Fit Text box to Contents
When you change font or style to the paragraph or even when you import texts from other
applications, the text box can be larger or smaller than its actual content: this command adjusts the
size of the selected text boxes.

Convert to Wall PRO
Convert To Wall applies to lines, polygons, arcs and curves. This function converts those objects
into walls with the current settings: select the items to convert and then choose Tools > Walls >
Convert To Wall on the Tools menu. This command is also available as a button in the Edit Tool Bar.

Rebuild Wall PRO
Use this command to regenerate the geometry, side intersections and nodes of one or more walls.
This is especially useful in situations in which a node needs to fixed.
The Rebuild Wall tool can either be applied to selected walls, or to multiple walls in one run by
clicking on them.
To use it on the selection:
1. Select the walls you want to rebuild
2. Choose Tools > Rebuild Wall or open the radial menu and choose Rebuild Wall from the Tools
submenu.
To apply it to multiple walls:
1. Choose Tools > Rebuild Wall or open the radial menu and choose Rebuild Wall from the Tools
submenu.
2. Click once on each wall to rebuild
3. Click on a void part or on another object to end.
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7. Organizing the Project

Chapter 7: Organizing the Project

▫ C r e a t i n g a n d O rg a n i z i n g L a y e r s
▫ C r e a t i n g a n d O rg a n i z i n g L i n e Ty p e s
▫ C r e a t i n g a n d O rg a n i z i n g H a t c h P a t t e r n s
▫ Colors
▫ T h e O rg a n i z e m e n u
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Drawing Manager Window
The Drawing Manager window allows you to organize important items of a project, such as layers,
line types, hatch patterns and colors. Select Organize > Drawing Manager to open it.

NOTE In HighDesign, resources like linetypes, hatch types, and symbols can be stored in
three libraries: the HighDesign Library, which is internal and cannot be edited; the User
Library, which extends the internal library with all the custom resources created by you; the
Project Library, which includes the items used in the project and can include any imported
resources that are available in the current project only.

Layers
Use the Layers pane to create, delete and organize layers for your project. For a description of
layers, see chapter 3.

Layers Manager
A. Default tool
B. Layer
name C. Number of objects
on each layer D. Visibility
E. Lock F. Color G. New
layer button H. Delete layer
button I. Action menu with
Selection options J. “Bind
Layers to Drawing Tools”
option.
Almost all operations on
layers can be performed via
the main layers table, where
each row displays all the
layer attributes.
The first column shows the drawing tool connected with the layer if the “Bind Layers to Drawing
Tools” option is selected. The second and the third columns display the layer name and the number
of items on each layer: double click to change the name. The last three columns display the layer
attributes: visible / invisible, locked / unlocked, default color.
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To reorder a row, just drag it to the new position: note that reordering has no visual eﬀect on the
display order of layers, but it allows you to keep them organized in a way that’s most convenient to
you.
To create or delete a layer use the buttons below the table; you can delete any layer anytime, but at
least one layer must always be present.
Both new layers and those imported from other documents are automatically set as document
layers only, meaning that they only exist within the owner project.
Layers can be associated to certain drawing tools with the “Bind layers to drawing tools” checkbox.
When this option is active, each drawing tool is linked to a layer: when you select a tool, its layer
automatically becomes active, thus simplifying the process of organizing a project. For instance, in
an architectural project freehand lines might only be used to design the landscape: linking the
“Freehand” tool to a “Terrain” layer is a convenient way of keeping the project organized without
having to change layer each time you change tool.

Linetypes
This pane lists the line types of the project. By default a new project comes with only few line types
available, continuous and various dashed lines. Use the Linetypes Manager to add more lines to the
project, create new types, edit custom lines, and organize the resources.
Available options in this pane include:

•
•
•
•
•

Load a saved linetype into the project or remove a type from the project
Create a new line type
Duplicate and edit custom line types
Delete a custom line type
Reorder the project linetypes
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The Linetypes Manager.
A. Line types available in the current project.
B. “Add Item” button: loads existing types from libraries.
C. New line type.
D. Duplicate selected line.
E. Delete selected line.
F. Preview.
G. Type-specific controls: with dashed lines, dash and space input fields up to 6 patterns; with
special line types, frequency and intensity.
H. Units menu.
I. Line name.

To create a new line type:
• Click the “New line” button;
• Select a base type from the “Line type” pop-up menu; according to the type, some of the dialog
controls get enabled allowing you to set the line type properties. There are two main families of
line types:

• Dashed lines with Dash and Space as available attributes. Insert a value in the current unit millimeters, decimal inches or pixels - at a 1:1 scale into the corresponding fields and click the
option buttons below the fields to add or remove a pattern to the line; you can add up to 6
diﬀerent patterns to a line type.

• Special line types with Frequency and Intensity attributes. Adjust the value by dragging the
corresponding control or insert it into the field.

99 | Chapter 7. Organizing a Project

• When the line type has been defined, push the “Save” button to save it to its default folder.

To duplicate an existing line type, click the “Duplicate” button and edit the duplicate line in the
same way as new lines. To delete a line type, select it and push the Delete button. You cannot delete
the default line types, but only the types created by you. Objects that use that type will be reverted
to Continuous line.
To add more linetypes to the current project, click on the folder icon with the “Add Items” label: the
existing line types are listed on the left and are arranged in “HighDesign Library”, the line types
provided by the application, and “User Library”, which stores the custom line types created by the
user. To load the selected line types into the project list, just drag items between the lists.
To disable a line type so that it is no longer available in the project, drag it from the project list to the
resources list.
The listing order of line types can be rearranged by dragging a line type to its new position.

Hatch Patterns
This pane lists the hatch patterns of the project and is used to create, edit and organize vector hatch
patterns. HighDesign provides two types of hatch fills:

• Linear hatches, made of parallel lines, continuous or with a specific dash pattern, with variable
oﬀsets and angle. A set of line type, angle, and oﬀsets is a skin. A linear hatch can have up to
eight overlaid skins.

• Tiled patterns. Each tile contains a drawing that is repeated inside hatched region.
On the left side of the pane a table displays all of the available hatch-types of the current project.
To add more hatch types to the current project, click on the folder icon with the “Add Items” label:
the existing hatch types are listed on the left and are arranged in “HighDesign Library”, the hatch
types provided by the application, and “User Library”, which stores the custom hatch types created
by the user. To load the selected hatch types into the project list, just drag items between the lists.
To disable a hatch type so that it is no longer available in the project, drag it from the project list to
the resources list.
The list order of hatch types can be rearranged by dragging a hatch type to its new position.
Custom types are highlighted with a diﬀerent background color.
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Hatch Patterns Manager. A. Resources. B. Load Resources. C. New Hatch or Pattern. D.
Duplicate item. E. Delete custom resource. F. Preview. G. Hatch layers. H. Hatch layer angle. I.
Hatch origin offset. J. Hatch spacing K. Dashed line pattern L. Alternate origin offset of dashed
pattern M. Hatch name.

The options of this pane are:
• Create a new hatch-type;
• Duplicate an existing hatch-type: select it from the table and click the “Duplicate” button;
• Modify an existing hatch-type;
• Delete a hatch-type.
To create a new Linear Hatch type.
• Click the “New hatch type” button and choose “New Linear Hatch” on the menu to create a new
temporary type;
• Click the “+” or “-” buttons to add or remove overlaid skins;
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• To change the angle either insert a value in degrees into the “Angle” field or adjust the angle
control;
• You can set the oﬀset of the origin of the current skin: the oﬀset is relative to the origin of the
hatch; the “DY” field is active only with dashed lines and indicates the oﬀset of the origin of all the
dashed lines of the skin.
• To change the distance between lines, insert a value into the “Spacing” field or adjust it by
dragging the spacing slider; distances are by default in the current metric or imperial system
(millimeters or decimal/fractional inches);
• The linetype can be continuous or dashed: select the linetype of the current skin from the
“Linetype” pop-up menu;
• If you selected the “Dashed” linetype, set the values of dashes and gaps (up to three dashes and
gaps);
• It is also possible to set the alternate oﬀset of dashed lines: with this option you can move the
origin of every second dashed line by the entered value:
• Use the text field to change the name of the current hatch;
• Push the “Save” button to save the new hatch type.
To duplicate an existing hatch type:
• Select a type from the types table and click the “Duplicate” button;
• Edit the attributes, then push the “Save” button to save the new type, or push “Cancel” to
dismiss.
To modify an existing hatch type:
• Select a custom type; note that only custom hatch types can be modified;
• Edit its attributes, then push “Save Changes...” to confirm the changes done, else push “Cancel”
to dismiss.
To delete an existing hatch type:
• Select a custom type; note that only custom hatch types can be deleted;
• Push the “Delete” button.

TILED PATTERNS
With this tool it is possible to create custom patterns for architecture and illustration.
If you select “New Tiled Pattern” on the “New hatch type” menu, HighDesign switches to the “Edit
Pattern” workspace which provides a new window and a limited set of drawing tools.
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In this environment the drawing scale is set as 1:1. Available drawing tools are Selection Arrow,
Construction Objects, Lines, Segmented Lines, Rectangles and Regular Polygons. The drawing area
is set by the size of the tile.
You can also Copy/Paste drawings from the main window of HighDesign: in this case we suggest to
set the size of the tile before pasting the pattern since tile, drawing area and pattern must have the
same size.
In the drawing area you can draw and edit the pattern exactly as in the main window. When the
pointer is close to the middle of the tile, the median axes show up providing a visual aid to mirror or
rotate objects.The preview window provides the fields to set the size of the tile and the zoom slider:
once the drawing is complete, just push the “OK” button in the preview window and the focus turns
back to the Hatch Manager.

Colors
Drawing items in HighDesign can have an indexed color from a palette of 256 colors. The Colors
pane provides shows the current palette and provides the option to bind a color to a pen weight, so
that choosing a pen color automatically sets the associated pen weight.
To bind a pen weight to a color, activate the “Bind colors to pen weight” option, click a color and
choose a pen weight from the pop-up menu; the selected pen number appears on the color box. To
remove a pen from a color, press the Option key on the keyboard and click the color box or choose
“none” from the pop-up menu.
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The color-pen binding works in one direction only: selecting a color also selects its pen weight, but
selecting a pen weight does
not change the current color.
This allows you to change
the pen weight of an object
at any time without aﬀecting
its pen color. Color-pen
bindings are saved in the
current document.
Drawing Manager - Colors
A. Colors table: click to
select a color index.
B. Color index
C. RGB, CMY and HSV
values of the selected color
(not editable).
D. Bind colors to pen weights option and pop-up menu.

Organizing Groups, Layers and Sheets
The Organize menu includes several commands and functions to help you in the organization of a
project: these include options to manage groups, layers and, in the Professional version, sheets.

Groups
Groups are a convenient way of organizing items by binding
heterogeneous items in one “group” which acts as one object. Once a
number of drawing objects are grouped together you can select them
simply by clicking any of the group members. By default, the grouped
objects retain their attributes, such as color, line type, weight, etc.
Changing the attributes of a group applies the changes to all its
members.
All functions related to groups area available in the Organize menu:
Group, Ungroup, Automatic Grouping, Ungroup All.
‣ “Group” creates a new group with all the currently selected items;
‣ “Ungroup” breaks the selected groups;
‣

“Add to Group” includes selected objects in the currently selected group;
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‣

“Automatic Grouping” is an option that automatically creates groups with items of a
shape, i.e. rectangles, regular polygons, polylines, walls, etc.;

‣

“Ungroup All” breaks all groups, including those not selected.

Grouped objects can be edited all together like a single drawing object by stretching the handles of
the bounding box of the group with the Arrow tool. A group can be moved, rotated, mirrored or
scaled like any other object.

Layers
These items provide some useful options for
layers and include:
‣ “New Layer”, a command to quickly create a
new layer; the New Layer dialog presents all the
option to set the properties if the new layer;
‣ “Layers” opens a sub menu with all the
currently available layers; select a layer to
activate it or change the layer attribute of the
selected items;
‣ “Show All Layers” makes all layers visible;
‣ “Hide Other Layers” makes all layers invisible
apart from the current one.
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Sheets
This group of items is used to organize and manage
project sheets. Available options are:
‣ “New Sheet” creates a new sheet and appends it to the
list; insert a name into the input dialog and push OK; the
new sheet is automatically activated;
‣ “Sheets” opens a sub menu with all project sheets;
select a sheet to activate it;
‣ “Transfer Objects To” is only available when there are
selected items and more than one sheet available; this
menu item opens a sub menu with all project sheets;
select one to transfer all selected items to that sheet;
‣ “Duplicate Objects To” makes copies of the selection
and sends them to a diﬀerent sheet;
‣ “Duplicate Sheet” makes a copy of the current sheet
and adds a “+” to its name;
‣ “Merge Visible Sheets” creates a new sheet containing
all those items belonging to visible sheets; please pay attention when using this command,
because source sheets are removed and this action cannot be undone;
‣

“Merge All Sheets” merges all sheets, including those not visible, into one sheet and
removes the source sheets; as for other similar items, this action cannot be undone;

‣

“Show All Sheets” and “Hide Other Sheets” make all sheets visible and all sheets invisible
apart from the current one respectively.
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8. Windows and Utilities

Chapter 8: Windows and Utilities

▫ The Window Menu
▫ Sidebar and Floating Panels
▫ Sheets and Layers
▫ Overview and Views
▫ Object Info and Styles
▫ Snaps Floating Window
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The Window Menu
This menu is divided into five sections, the first of which provides commands related to the main
window: Minimize, acts by reducing the window to the Dock; Zoom Window expands the main
window to fill the available screen bounds (these do not include the menu bar and the dock region).
The second section includes Rulers and Scrollbars
(show or hide the rulers and the scrollbars on the
main window and are global, application preferences),
Sidebar and Floating Panels: by selecting Sidebar, all
utility windows are displayed as panels arranged in a
sidebar on the right side of the main window, whereas
if you choose Floating Panels, the utility windows are
displayed as three floating panels, very useful if you
work with two displays.
The third section has commands used to show or
hide the Sheets & Layers, Overview & Views and
Object Info & Styles floating panels: this section is
active only if the “Floating Panels” option is selected.
Bring All to Front applies to all project windows minimized to the dock; Enter Full Screen expands
the application window to fit the extents of the screen, hiding the window frame, the Menu Bar and
the Dock.
The last section of the “Window” menu displays a list of all currently open project windows: select a
window name to bring it to the front.

Sidebar and Floating Panels
Utility windows such as Sheets & Layers, Overview & Views and Object Info & Styles provide the
commands to manage functional features of HighDesign. Depending on the selected display option
on the Window menu, these windows can either be arranged in a sidebar or shown as floating
panels which you can move through the main window or externally.
The Sidebar is located on the right edge of the main window and displays the windows as panes
organized in three groups.
Each of the three Floating Panels include two panes to access the corresponding functions of the
utility windows.
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Sheets and Layers
SHEETS
Use this pane to organize project sheets. By using this palette you can quickly create, rename
and delete sheets, change their visibility, protection, size and scale attributes.
To create a new sheet, click the New Sheet button (+) and modify its name. By default, new
sheets are created with the current drawing scale and units. You can change the units and
scale of a sheet by double-clicking it on this window.
To arrange a sheet, drag it to the new position: the table order corresponds to the actual
display order, where the topmost visible sheet is the first item of the list.
You can control how the sheets are displayed on screen by clicking the Opacity button. There
are two states: all sheets equally visible or only the current sheet displayed normally and the
others dimmed.
A. Sheet size: double-click to change;
B. Visibility;
C. Sheet Protection: click to switch;
D. Drawing scale and units: double-click to change;
E. Sheet name: double-click to rename;
F. New sheet;
G. Delete sheet;
H. Action menu.

The action menu lists the commands to manage sheets as in
the Organize menu, apart from those specific to the selected
objects of the drawing, and the commands to change the
visibility status of all sheets in relation to the current one.
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LAYERS
The Layers pane is a diﬀerent way to display the same functions
to manage layers as you can find on the Layers menu of the
Properties bar and on the Radial menu: you can switch to other
layers, show or hide layers, lock some layers and access the
Layers Manager to create and arrange new layers.
Since managing layers is one of the most used functions of
technical drawing, it is very useful being able to access these
functions in many ways.

The current layer is highlighted with the darker blue color, while layers of selected objects are
highlighted with a light gray color. To move the selected objects from one layer to another, click the
right arrow next to the destination layer.
The buttons on the footer of the window allow to create and delete layers, open the Layer Manager
and switch layer masking on and oﬀ.

Overview/Zoom and Views
This panel provides three functions: Live Zoom, Project Overview and Project Views.
Live Magnification: with the “Zoom” pane active this panel displays a
real-time 3x magnification of the current pointer location; a crosshair
cursor changes color according to the snap status: cyan for normal
status (no active object), yellow for snap to object and magenta for
snap to vertex.

Project Overview: when the pointer enters the palette, the zoom view
changes to a preview of the currently visible project drawings; click on
the preview to center the main view to the corresponding location.
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PROJECT VIEWS
In HighDesign Professional a Project View is a handy way to create layouts ready for printouts:
through the Project Views pane it is possible to create new views of your project and to browse
through existing views.
A project view stores the visibility status of current sheets and layers and allows you to create for
instance a "layout" of a plan with dimensions and surfaces and another "layout" of the same plan
(sheet) with services only.
By combining visible sheets and layers you can create complex project views for your printouts: in
the Print window you can select the Project View you wish to print through the Views menu.
Views Manager: the “Views” pane provides a list of
all saved project views. A live preview of the views
shows up when the pointer is over a view’s name.
Click on a view’s name to activate it or doubleclick to rename.
To add a view, click the “Save current view” button
and type a name: saved views include position,
magnification factor, and visible sheets and layers.
To delete the currently selected view, click the
“Delete View” button. The Update View button
redefines the selected view from the current settings.

Object Info and Styles
OBJECT INFO
The Object Info pane provides easy access to coordinates and other numerical values of the
selected object. You can use this pane to read and set the coordinates of any of the control
points of the object, width, height, length, angle, etc., according to the type of object.
By default, Object Info modifies all the selected objects of the same type. To modify only the
current object, whose values are displayed on the panel, open the pop-up menu on the header
of the panel and choose “Apply Only to Current Object”. This option stays selected until
changed again.
The window is organized into four sections: current object info, current point coordinates, size,
computed values.
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When you select one or more objects in the drawing, Object Info immediately displays all the
numerical properties of the last selected object. The icon and name of the current object are
displayed on the top bar of the window, along with the back and forward arrows used to
browse through the objects in the selection. When the object has special properties, like texts
or dimensions, the icon can be clicked to open the corresponding properties window.
The next section displays the X, Y coordinates of the current point. The current point is
highlighted in the drawing, and you can use the back and forward circular buttons to scroll
through the handle points of the object. To change a value, click the field, insert the new value
and press the Return key on the keyboard. Depending on the type of object and the active
point, the resulting action can either be a stretch or a move. For instance, if you edit Point 2 of
a line, it is stretched; if you edit Point 3 of a circle (its center), the action is a move.
The middle section displays values describing the size and orientation of the object, like width,
height, radius, length, angle, etc. Fields like Width and Height can be connected to constrain
the proportions of the object.
The last section displays read-only values that are computed by the current coordinates and
size, like perimeter and area.
Some objects, like dimensions and measure paths, only display their value in a read-only field,
since they are actually dependent on other objects for their size.
Object Info
A. Object Icon, type and Back and Forward arrows to browse the
selection. With multiple selections, this is a pop-up menu with a list of
the selected objects and options to: 1) deselect all the other objects;
2) Apply the changes only to the current object.
B. Active point coordinates.
C. Size and orientation info.
D. Computed values (read-only).
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STYLES
A style is a predefined set of properties and behaviors that you can apply to graphic objects
with a double-click. A style stores the current settings of layer, pen and fill color, arrowheads,
line type and pen weight, and can be generic or tool-specific.
Generic styles can be applied to all kind of graphic objects. Properties that are not supported
in one type of object are ignored.
Tool-specific styles apply only to the tool they were created for: when you click a tool specific
style, the corresponding tool and method activate. This type of style also include all the
properties specific to their tool: for example, if you create a text style, it stores the current
settings of the Text tool, such as font, size, alignment, etc.
By default, a style exists only inside the document it was created in. However, you can save a
style on disk and load it into any other document.
Styles can be created and managed through the Styles window. You can open a drop-down
menu by clicking the triangle to the right of the name of a style on the Styles window.

Styles Window and Menu - A. No style B. Tool-specific style C. Generic style D. New style
from properties or selection E. Delete current style F. Update selected style by current
properties G. Style management menu.

Creating new styles
Click the “New Style” button (+) on the Styles pane. The “New Style” window lets you enter
the name, set the type and select the properties you want the style to control.
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For example, if you create a style that stores layer, color and line type, but no other properties,
when you apply it to an object it will change only those properties.
In the New Style window, when the type is set to Generic, the General Properties section lists
all the items of the Properties bar, regardless of the current tool; when the type is tool-specific,
it lists all the properties that are not overridden by the tool properties. The Tool Properties
section is only enabled with tool-specific styles and signals that the new style will also include
all the properties that are specific to the current tool, if available.
To create a style from an existing object, simply select the object and click the “New Style”
button or choose “Create New Style from Selection” from the pop-down menu on any row of
the Styles window.

Applying styles
To apply a style to one or more objects, select the objects and click the style name on the
Styles window.
To remove a style from an object, select the objects and click “None”
When you apply a style, its properties are applied to the selected objects.
Updating a style
If you change a graphic property in the properties bar when a style is active and selected in
the Styles window, the current style signals the changes to its original parameters by showing
the name in italics and the menu triangle in red.
To update the style and match the new properties, click the “Update Style” button on the
Styles window.
When a style is updated, all the objects that use it are automatically updated to match the new
properties. For example, if you update the font of a “Plan Dimensions” style, all the
dimensions that use that style will change their font accordingly.
Modifying a style
To change the settings of a style, such as its name, type and active properties, select it on the
Styles window and choose “Modify Style” from the pop-down menu.
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New Style / Modify Style
A. Style name
B. Type, generic or toolspecific. The latter option is
not available with all tools.
C. Properties table. When type
is set to Generic, the
General Properties section
lists all the items of the
Properties bar, regardless of
the current tool; when type
is tool-specific, it lists all the
properties that are not
overridden by the tool
properties. The Tool
Properties section is only
enabled with tool-specific
styles.
Renaming a style
To rename a style, open the pop-down menu and choose “Rename” or double-click the style
name on the Styles window.
Reordering styles
You can rearrange the order in which styles are listed by dragging a row in the Styles window.
You cannot reorder the first row.
Deleting a style
Select the style on the Style window and click the “Delete Style” button (–), or choose “Delete
Style” from the pop-down menu.
If there are any objects in the project using that style, a dialog lets you choose a new style to
replace the one you are deleting. The objects whose style is replaced are updated to match
the new style.
Saving and loading a style on disk
You can save a style on disk for later use in diﬀerent projects.
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Choose “Save Style” from the pop-down menu and select the destination location. By default,
the preferred location is the Styles folder inside the HighDesign Support folder (...user / Library
/ Application Support / Ilexsoft / HighDesign / Styles).
To load a saved style in a project, choose “Load Style” from the pop-down menu on the Styles
window.
Reverting a style
When the current style has been temporarily modified by changing one of the graphic
properties in the Properties bar, you can revert it to its original properties by choosing “Revert
to Original Style” from the pop-down menu.
Finding all uses of a style
Open the pop-down menu of the style and choose “Select All Uses of [style name]”. All the
objects on the current sheet using that style are selected.

Snaps Window
The snap options and the drawing constraints can be
displayed as grouped in a small floating window: you can
move this window throughout the drawing area. To show
this option, select “Snaps” on the Window menu.
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