HighDesign R5 Zoom, Selection, inertial scrolling

General HighDesign Discussions
Post Reply
bdgWesternMass
Posts: 8
Joined: Tue Apr 10, 2018 10:02 pm

HighDesign R5 Zoom, Selection, inertial scrolling

Post by bdgWesternMass »

I tried to use HighDesign 2017 and at times it was great and at other times, some sort of strange zoom scrolling, with a sort of interval delay takes over. I could never figure out what was going on but it always seemed like mouse events were getting lost or arriving way late.

I was quite excited to get my hands on R5 because the event system was suppose to be redone.

Well I don't know what to say be I have the same issues I wish I knew a better way to describe it. It is as if I'm using a Remote Desktop that is updating events way late or coming up with it's on events.

I'm on OS X 10.14 on an iMac Pro with 128 GB of RAM Radeon Pro Vega 64 16 GB 3 GHZ Intel Xeon W.

This time things were going ok until I got into symbol editing. I was trying to add attributes. Maybe they are related.
I tried to turn off all the auto scrolling zoom features. Which brought to my attention that the magnifying tool has disappeared. I guess that was my crutch.
Can anybody confirm this strange experience?

bdgWesternMass
Posts: 8
Joined: Tue Apr 10, 2018 10:02 pm

Re: HighDesign R5 Zoom, Selection, inertial scrolling

Post by bdgWesternMass »

Well I found the magnification tool on the opposite side of the drawing of the rest of the tools. It actually also has the hand tool and the zoom to fit.

This seems like a nice tidy collection of tools but in an unexpected place, the first time:)

User avatar
Andrew
Site Admin
Posts: 531
Joined: Thu Apr 29, 2004 2:16 pm
Location: Ilexsoft HQ
Contact:

Re: HighDesign R5 Zoom, Selection, inertial scrolling

Post by Andrew »

Hi, you can change the location of the view tools to any of the sides or corners of the drawing area, or place them back into the main toolbar as in HD 2017. Right-click on one of the icons and select the new placement, or go to Preferences > Workspace > View Controls.

Click the attached gif to view a demonstration.
View_dock_right_click.gif

John Compiani
Posts: 71
Joined: Thu Nov 28, 2013 9:56 am

Re: HighDesign R5 Zoom, Selection, inertial scrolling

Post by John Compiani »

bdgWesternMass wrote:
Mon Aug 26, 2019 10:19 pm

Can anybody confirm this strange experience?
Yes. Very laggy.

The graphics engine doesn't appear to have had much of an upgrade.

When you move objects instead of them being smoothly rendered as you move them they are replaced with a blue rectangle. Which flickers when moved and doesn't move smoothly.

And viewports contents are replaced by a cross if you try and reposition them so you have to guess where your drawing will end up.

And in 20 minutes of using the app I've run into loads of issues and bugs.

Edit: Snipped a few unnecessary comments.
Last edited by John Compiani on Wed Aug 28, 2019 8:32 am, edited 1 time in total.

User avatar
Andrew
Site Admin
Posts: 531
Joined: Thu Apr 29, 2004 2:16 pm
Location: Ilexsoft HQ
Contact:

Re: HighDesign R5 Zoom, Selection, inertial scrolling

Post by Andrew »

John Compiani wrote:
Tue Aug 27, 2019 11:46 am
And in 20 minutes of using the app I've run into loads of issues and bugs.
Please do send detailed reports, otherwise we have no chance to address the issues that you've run into and thus improve your experience with the software. Thank you.

bdgWesternMass
Posts: 8
Joined: Tue Apr 10, 2018 10:02 pm

Re: HighDesign R5 Zoom, Selection, inertial scrolling

Post by bdgWesternMass »

Hello Andrew,

I know how difficult software creation is and for whatever reason I really want to use High Design.
Here is the simplest example I can come up with.

I open a drawing in High Design R5.
I try to navigate the drawing at the current scale but instead of navigate the drawing the scale is zooming in or out.
I decide that it looks like the mouse surface is acting as scroll wheel. I have turned off this before with the use Scroll wheel to zoom checkbox along with auto-scrolling. I'm not against auto-scrolling but I have no idea what is going on and auto-scrolling sounds bad.

I look in preferences and see they are both checked so I uncheck them. Once I again I try to move around the drawing doing things and suddenly I'm zooming way out. I try compensate and zooming way in. All of it is stuttering and the drawing will not become responsive for between 5 and 10 seconds while it changes between zooming in and out.

When it does settle down I might be able to start working but if I click on the drawing it starts to pan around which of Course causes delays.

I also find that even with use scroll-wheel for zooming turned off the system will still pan around with the scroll wheel with no way to disable it. This will also cause lengthy delays in the interface while I wait for it to redraw.

The file I'm using has a 20 MB which I sure is mostly the my background layer image.
Finally I was just looking in my project to find out exactly what image is I'm using for my background and I was surprised not to see the embedded images listed under:

Project-->Resource Manager.

I would expect somewhere in the program to be able to track down at least the path name of embedded images or their file size as a minimum.

Please let me know how to work out these issues.

Thank you for your effort,

Ben

User avatar
Andrew
Site Admin
Posts: 531
Joined: Thu Apr 29, 2004 2:16 pm
Location: Ilexsoft HQ
Contact:

Re: HighDesign R5 Zoom, Selection, inertial scrolling

Post by Andrew »

Thank you for your feedback. I'll try to answer your questions:

bdgWesternMass wrote:
Tue Sep 17, 2019 1:50 pm
I open a drawing in High Design R5.
I try to navigate the drawing at the current scale but instead of navigate the drawing the scale is zooming in or out.
I decide that it looks like the mouse surface is acting as scroll wheel. I have turned off this before with the use Scroll wheel to zoom checkbox along with auto-scrolling. I'm not against auto-scrolling but I have no idea what is going on and auto-scrolling sounds bad.
Are you using a mouse, as it would seem, or a trackpad?
We designed the drawing navigation with the idea of keeping it as close as possible to the standards used in almost every other CAD software, but of course there may be differences depending on whether you use a trackpad or a mouse. Also, depending on the type of mouse, you might have assigned different functions to the various buttons which could interfere with the navigation.

With the standard settings, to zoom the drawing you use the mouse scroll wheel to zoom in and out. Hold down Option (Alt) to scroll vertically, Option + Shift to scroll horizontally.

To pan, press the space bar or the middle mouse button (the scroll wheel). In Preferences > Workspace, you can activate the long-click to pan, that is the ability to start panning by clicking and holding down the click, like you would do to drag an item on the desktop.

In the Preferences, you can adjust the zooming speed, which also depends on your system settings, reverse the zooming direction, or disable zooming altogether. When zooming is disabled, scrolling becomes the default action when you move the scroll wheel.

Auto-scrolling starts when, during the construction of an object, you reach the border of the drawing area. To avoid having to pan or zoom out, auto-scrolling moves the drawing to that direction. In the past we had users complain about it being too fast, so we slowed it down considerably.

I look in preferences and see they are both checked so I uncheck them. Once I again I try to move around the drawing doing things and suddenly I'm zooming way out. I try compensate and zooming way in. All of it is stuttering and the drawing will not become responsive for between 5 and 10 seconds while it changes between zooming in and out.

When it does settle down I might be able to start working but if I click on the drawing it starts to pan around which of Course causes delays.
That really depends on the complexity of the drawing and if there are high-resolution images displayed.

I also find that even with use scroll-wheel for zooming turned off the system will still pan around with the scroll wheel with no way to disable it. This will also cause lengthy delays in the interface while I wait for it to redraw.
That is the default system action. We could add an option to disable even scrolling, which should possible via the System Preferences anyway.

The file I'm using has a 20 MB which I sure is mostly the my background layer image.
Finally I was just looking in my project to find out exactly what image is I'm using for my background and I was surprised not to see the embedded images listed under:

Project-->Resource Manager.

I would expect somewhere in the program to be able to track down at least the path name of embedded images or their file size as a minimum.
Images are not project resources, that is, they are not external references that must be loaded with the project. Once you insert an image, it is a project item just like any other object. This ensures the easy portability of the project file.

In the future, we'll add schedules and project lists, so you can manage all the project items including embedded images. Now you can use the Find function under the Edit menu to find all the images inserted in the project.

bdgWesternMass
Posts: 8
Joined: Tue Apr 10, 2018 10:02 pm

Re: HighDesign R5 Zoom, Selection, inertial scrolling

Post by bdgWesternMass »

Quoting is difficult so I will just answer in the order asked.

I'm using a mouse but it certainly does feel like a trackpad is involved. I assumed it was caused by use of a Magic Mouse which essentially is a mouse with a trackpad on top. Finally I do always have a trackpad hooked up but it is kept out of the way when not in use.

I'm trying to make my mouse as generic as System Preferences-->Mouse allows.

I have only ever used High Design with this computer so it could be something weird with the trackpad. I have always described the issue as if High Design is missing UI events... I will turn off the trackpad and report back.

I will also try to use the mouse and control keys as you describe.

I always disable zooming because I want the program to calm down and I thought the less magic the better.

I will watch closely for what you describe with auto-scrolling.

I agree that System Preferences-->Mouse is missing at least one tick-box.

What is an appropriate file size range for embedding images for underlays or ....

Thanks,

Ben

Post Reply